gfx/tests/Makefile.in - commented logic

RESOLVED DUPLICATE of bug 865902

Status

RESOLVED DUPLICATE of bug 865902
5 years ago
6 months ago

People

(Reporter: joey, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
gfx/tests/makefile.in - logic commented out back in 2011.

If still needed this bug can be used to revive the logic.
If not commented block can be removed to cleanup the makefile.

changeset:   70003:8e846d7f21ea
date:        Mon May 23 18:54:47 2011 +0200
summary:     Bug 648911 - Remove support for non-libxul builds. r=ted,joedrew

 70003: # CPP_UNIT_TESTS disabled for now because they dont work in libxul builds.
 70003: #ifndef BUILD_STATIC_LIBS
 70003: #
 70003: #CPP_UNIT_TESTS = \
 70003: #               TestColorNames.cpp \
 70003: #               TestRect.cpp \
 70003: #               TestRegion.cpp \
 70003: #               $(NULL)
 70003: #
 70003: ## These are built but not run.  gfxColorManagementTest.cpp can't even
 70003: ## be built, because it has not been updated for qcms.
 70003: #CPP_DISABLED_UNIT_TESTS = \
 70003: #               gfxFontSelectionTest.cpp \
 70003: #               gfxSurfaceRefCountTest.cpp \
 70003: #               gfxTextRunPerfTest.cpp \
 70003: #               gfxWordCacheTest.cpp \
 70003: #               $(NULL)
 70003: ##              gfxColorManagementTest.cpp \
 70003: #
 70003: #
 70003: ## rules.mk will put the CPP_UNIT_TESTS into SIMPLE_PROGRAMS twice if we
 70003: ## define SIMPLE_PROGRAMS based on CPPSRCS directly.
 70003: #CPPSRCS                = $(CPP_DISABLED_UNIT_TESTS)
 70003: #SIMPLE_PROGRAMS        = $(CPP_DISABLED_UNIT_TESTS:.cpp=$(BIN_SUFFIX))
 70003: #
 70003: #ifeq ($(MOZ_WIDGET_TOOLKIT),cocoa)
 70003: #CMMSRCS                = gfxTestCocoaHelper.mm
 70003: #HELPER_OBJS    = gfxTestCocoaHelper.$(OBJ_SUFFIX)
 70003: #EXTRA_DEPS     += gfxTestCocoaHelper.$(OBJ_SUFFIX)
 70003: #endif
 70003: #
 70003: #LIBS           = \
 70003: #               $(HELPER_OBJS) \
 70003: #               $(call EXPAND_LIBNAME_PATH,thebes,../thebes) \
 70003: #               $(call EXPAND_LIBNAME_PATH,gkgfx,../src) \
 70003: #               $(MOZ_UNICHARUTIL_LIBS) \
 70003: #               $(XPCOM_LIBS) \
 70003: #               $(MOZ_JS_LIBS) \
 70003: #               $(TK_LIBS) \
 70003: #               $(NULL)
 70003: #
 70003: #endif
(Reporter)

Updated

5 years ago
Blocks: 870802
(Reporter)

Updated

5 years ago
Blocks: 870806
(Reporter)

Updated

5 years ago
Blocks: 870815
We should probably just file a bug to get these converted into gtests.
I have a patch in bug 865902 to add a 2 of these into gtest. Any takes for the other tests?
Depends on: 865902

Updated

5 years ago
No longer blocks: 870815

Updated

5 years ago
No longer blocks: 870806

Updated

5 years ago
No longer blocks: 870802

Updated

5 years ago
Blocks: 847009
Alright the patch in bug 865902 removes all these test and cleans up the Makefile.
Duping to 865902 since it removed everything.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865902

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.