applets fail to load from a chrome

RESOLVED INVALID

Status

RESOLVED INVALID
18 years ago
8 years ago

People

(Reporter: jevans12, Assigned: James.Melvin)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jpibug])

(Reporter)

Description

18 years ago
I have a xul file registered as a chrome. In this xul file I have an applet.
When I invoke moz(v0.9.1) with 
mozilla -console -chrome chrome://appletInChrome/content/appletInChrome.xul
The java plug-in(v1.3.1) reports

java.net.MalformedURLException: unknown protocol: chrome
(Reporter)

Comment 1

18 years ago
java.net.MalformedURLException:unknown protocol: chrome
at java.net.URL <init>(URL.java:480)
at java.net.URL <init>(URL.java:376)
at java.net.URL <init>(URL.java:330)
at.sun.plugin.navig.win32.PluginObject.setDocumentURL

I tried specifing the applet with both html:applet and html:object tags
although I need liveconnect so due to other LC bugs im using applet tag.

<!---
<html:APPLET name="DynamicDocCom" 
code="DynamicDocCom" 

archive="dynamicdoccom.jar, weblogic.jar, xerces.jar" 
width="1"
height="1" 
id="com"
codebase="http://www.hitrun.net"
MAYSCRIPT="true"> 

<html:param   name="param1"	 value="file:///platform.cfg"/> 
<html:param   name="param2" 	value="file:///generic.cfg"/> 
<html:param   name="param3"	 value="alerts"/> 
<html:param   name="param4" 	value="beatest1"/> 
</html:APPLET>  
-->
OBJECT TAG
<html:object
classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
id="com"
width="1"
height="1"
archive="dynamicdoccom.jar,weblogic.jar, xerces.jar"
name="DynamicDocCom" 
code="DynamicDocCom"
>

<html:param name="type" value="application/x-java-applet;version=1.3"/>
<html:param name="codebase" value="http://www.hitandrun.net"/>
<html:param name="scriptable" value="true"/>
<html:param name="mayscript" value="true"/>
</html:object>

Comment 2

18 years ago
This is a very interesting bug.  Please be aware that the java plugin uses 
java.net for non all protocols save HTTPS.  This means that if java doesn't 
have a protocol handler for chrome, it will just fail.  This smells like an 
RFE.  I'll file it that way into sun's bug system.

Comment 3

18 years ago
I have filed bugtraq bug 4475610 as an RFE on this.
Assignee: edburns → James.Melvin
Whiteboard: [jpibug]

Comment 4

18 years ago
jpibug invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 5

18 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Updated

16 years ago
QA Contact: pmac → petersen

Comment 6

16 years ago
*** Bug 199740 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.