Closed Bug 870884 Opened 7 years ago Closed 6 years ago

keon camera fails to start after build and flash form master b2g branch

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 898796

People

(Reporter: andre, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130508 Firefox/23.0
Build ID: 20130508031113

Steps to reproduce:

I've fetched the repository, built and flashed my Geeksphone Keon with the current master branch. The version is 1.1.0.

I am attaching a log from adb logcat, it shows an some errors from the camera.


Actual results:

The camera app stopped working. It shows a back screen instead of the preview image.


Expected results:

The camera should have kept working.
I see the following in the log:

E/mm-camera(  113): Waiting for frame thread to start ! 
V/QualcommCameraHardware(  113): runFrameThread E
E/mm-camera(  113): Wait over, frame thread ready !!!! 
V/QualcommCameraHardware(  113): initPreview X: 1
I/QualcommCameraHardware(  113): preview_thread E
  ....
E/mm-camera(  113): camera_issue_ctrl_cmd: error (Connection timed out): type 39, length 0, status 64064
E/QualcommCameraHardware(  113): native_start_ops: type 0 error Connection timed out
I/QualcommCameraHardware(  113): deinitPreview E
I/QualcommCameraHardware(  113): deinitPreview X
V/QualcommCameraHardware(  113): cam_frame_flush_video: in n = 0
V/QualcommCameraHardware(  113): cam_frame_flush_video: out n = 0
E/QualcommCameraHardware(  113): startPreview X: native_start_ops: CAMERA_OPS_STREAMING_PREVIEW ioctl failed!
I/QualcommCameraHardware(  113):  getBuffersAndStartPreview : X 
V/QualcommCameraHardware(  113): startPreview X
E/QualcommCamera(  113): Qint android::start_preview(camera_device*): X
I/QualcommCameraHardware(  113): preview_thread X
I/QualcommCameraHardware(  113): receive_camframe_error_timeout: X

It looks like the camera hardware isn't responding, although the logcat doesn't say why.

Inder, any idea what could be the problem?
Flags: needinfo?(ikumar)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Flags: needinfo?(ikumar)
If the ioctl is failing, this is very likely a problem with the kernel driver, which means support will need to come from Geeksphone.
Is this still happening, with a newest build?

I am asking because at http://forum.geeksphone.com/index.php?topic=4834.msg58251#msg58251 says that "camera works again..."

I will test it soon, but if you have any newer feedback please reply here.
Flags: needinfo?(andre)
Rebuilt from the master branch.

Test #1 - Camera launched and asked for Geolocation permissions, I denied permissions and the camera worked fine. 

Test #2 - Rebooted the device and launched the camera app again, it asked for geolocation permissions, granted them, camera stopped working. 

Test #3 - Removed the permissions, switched off the GPS, rebooted. Launched camera for the third time, it asks for geolocation permission, deny permissions and it works fine.

Test #4 - Changed GPS the permissions on the camera app from "deny", to "ask" and the camera stopped launching. Rebooted the device, the camera launched showed the image and a couple seconds later, asked for GPS permissions. Granted the permissions, the app kept working. Rebooted. Camera stopped working!!! Rebooted again. Camera still not working!

Test #5 - Changed the GPS permissions on the camera app from "grant" to "ask" and rebooted the device. Camera didn't launch. Change the permissions from "ask" to "deny" and rebooted. Camera is back working. Rebooted again. Camera still works!!!

Problem recipe found: Camera stops working if you grant it GPS permission and reboot. After you grant the GPS permission, the camera still works, it just fails to launch after rebooting the device. If the permissions are removed and the device is rebooted, then the camera resumes working.

I have no clue why this is happening but it is consistent here. Whenever the Geolocation permission is set to true and the device reboots, the camera fails.

What more can I do to help?
Flags: needinfo?(andre)
(In reply to andre from comment #4)
> Rebuilt from the master branch.
   ...
> What more can I do to help?

Andre, can you make a debug build...
# B2G_DEBUG=1 ./build.sh

...and then modify /system/bin/b2g.sh on the Keon to include |export NSPR_LOG_MODULES=Camera:4| right before the call to /system/b2g/b2g ?

This enables camera logging.  With that in place, please capture two logcats: one where the camera starts successfully, and one where it doesn't start.  (Any of the scenarios in comment 4 should be fine).
Sorry for the delay.

I did that with a new build from current source in the repo and I could no longer reproduce the camera bug after the first-time setup. After the first-time setup, camera was not working but after rebooting the phone the camera worked well. The camera kept working thru all the recipes and restarts mentioned above. I am attaching a log file and all the info should be there. This build was done with the instructions from above.
The camera bug still present on both the stable and the nightly channels. Even the ROM images being distributed by Geeksphone have that bug. Tested those images in six keons, the camera didn't work in any of them.
I build and flashed master FirefoxOS ROM on unagi. Camaera app crashed on the app start.
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> I build and flashed master FirefoxOS ROM on unagi. Camaera app crashed on
> the app start.

It seems like different problem. I am going to create another bug for it.
(In reply to Sotaro Ikeda [:sotaro] from comment #9)
> 
> It seems like different problem. I am going to create another bug for it.

Sotaro, can you add that new bug number here?
Sorry, it was Bug 882328 and was already fixed.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898796
You need to log in before you can comment on or make changes to this bug.