calendar startup crash in calICSService::ParserWorker::ParserWorkerCompleter::ParserWorkerCompleter @ nsXPCWrappedJS::AddRef

RESOLVED FIXED in 2.6

Status

Calendar
General
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Christian Riechers, Assigned: jdm)

Tracking

({crash, regression})

Trunk
crash, regression

Details

(Whiteboard: [startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

start Thunderbird
Version 23.0a1
Build ID 20130510085725


Actual results:

TB crashes right on start-up.
ID: bp-8e91597b-92c7-48d6-b9ef-e441b2130510
Signature: nsXPCWrappedJS::AddRef()
(Reporter)

Comment 1

5 years ago
OS is openSUSE Linux 12.3.
Crash Signature: [@ nsXPCWrappedJS::AddRef() ]
Keywords: crash

Updated

5 years ago
Blocks: 770840
Severity: normal → critical
Component: Untriaged → General
Keywords: regression
OS: Linux → All
Product: Thunderbird → Calendar
Hardware: x86 → All
Version: 23 → Trunk

Updated

5 years ago
Summary: crash [@ nsXPCWrappedJS::AddRef() ] → crash in calICSService::ParserWorker::ParserWorkerCompleter::ParserWorkerCompleter @ nsXPCWrappedJS::AddRef

Comment 2

5 years ago
patch in bug 770840 is currently backed out on trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash in calICSService::ParserWorker::ParserWorkerCompleter::ParserWorkerCompleter @ nsXPCWrappedJS::AddRef → calendar startup crash in calICSService::ParserWorker::ParserWorkerCompleter::ParserWorkerCompleter @ nsXPCWrappedJS::AddRef
Whiteboard: [startupcrash]
(Assignee)

Updated

5 years ago
Blocks: 773610
No longer blocks: 770840
(Assignee)

Comment 3

5 years ago
This will need an identical solution to bug 873615 - ParserWorker doesn't actually use mListener, it just needs to hold on to an nsMainThreadPtrHandle and pass that to ParserWorkerCompleter (which also needs to hold an nsMainThreadPtrHandle).
Josh, thanks for the info! Since you obviously know what you are doing, do you think you could put together the calendar patch for us?
(Assignee)

Updated

5 years ago
Assignee: nobody → josh
(Assignee)

Comment 5

5 years ago
Created attachment 751282 [details] [diff] [review]
Avoid addreffing a JS calendar listener off the main thread. r=
Attachment #751282 - Flags: review?(philipp)
Comment on attachment 751282 [details] [diff] [review]
Avoid addreffing a JS calendar listener off the main thread. r=

Perfect, thanks alot! r=philipp
Attachment #751282 - Flags: review?(philipp) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/1204d2bb361b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.6
Backed out for build bustage.
https://hg.mozilla.org/comm-central/rev/81898db42ab6

https://tbpl.mozilla.org/php/getParsedLog.php?id=23489810&tree=Thunderbird-Trunk
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/comm-central/rev/3ac3e87c62d5
(Assignee)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
This bug is marked as RESOLVED FIXED, however, TB Daily, Build ID 20130612030727 is still crashing. In fact, it is always crashing for me at start-up.
Linux openSUSE 12.3.
ID: bp-f513b7d8-13b0-4db0-adcc-30dc82130613
Signature: nsXPCWrappedJS::AddRef()

Comment 11

5 years ago
Christian, ensure that you are using a Lightning 2.6a1 nightly build that contains the fix i.e. was created after 2013-05-28.
(Reporter)

Comment 12

5 years ago
(In reply to Stefan Sitter from comment #11)
Thanks, this did the trick.
You need to log in before you can comment on or make changes to this bug.