If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Metro crash in nsXPCWrappedJS::CallMethod

RESOLVED DUPLICATE of bug 870782

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 870782
5 years ago
3 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

23 Branch
All
Windows 8.1
crash, regression
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23 affected)

Details

(crash signature)

(Reporter)

Description

5 years ago
The stack trace is different from the one in bug 870782.

Signature 	nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) More Reports Search
UUID	6db94a41-3214-4088-b5a6-4fe3f2130511
Date Processed	2013-05-11 06:52:36
Uptime	61
Install Age	1.0 minutes since version was first installed.
Install Time	2013-05-11 06:51:11
Product	MetroFirefox
Version	23.0a1
Build ID	20130510041606
Release Channel	nightly
OS	Windows NT
OS Version	6.2.9200
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 53 stepping 1
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x5a0e30db
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x08cf, AdapterSubsysID: 18f6103c, AdapterDriverVersion: 9.14.3.1087
D2D! D2D+ DWrite? DWrite+ D3D10 Layers! D3D10 Layers+ 
Processor Notes 	sp-processor09_phx1_mozilla_com_24606:2012; non-integer value of "SecondsSinceLastCrash"; WARNING: raw_crash missing Add-ons
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x08cf
Total Virtual Memory	2147352576
Available Virtual Memory	1774239744
System Memory Use Percentage	64
Available Page File	2749935616
Available Physical Memory	749314048
Accessibility	Active

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:573
1 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:85
2 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:112
3 	xul.dll 	FindProviderFile 	xpcom/io/nsDirectoryService.cpp:362

More reports at:
https://crash-stats.mozilla.com/report/list?product=MetroFirefox&signature=nsXPCWrappedJS%3A%3ACallMethod%28unsigned+short%2C+XPTMethodDescriptor+const*%2C+nsXPTCMiniVariant*%29

Comment 1

5 years ago
Looks like the same problem as on mobile: there's a JS-implemented directory service provider, and the directory service is being used off the main thread.

Comment 2

5 years ago
My suspicion is bug 870782 may resolve this, however.

Updated

5 years ago
Blocks: 773610

Updated

5 years ago
No longer blocks: 770840
(Reporter)

Comment 3

4 years ago
(In reply to Josh Matthews [:jdm] from comment #2)
> My suspicion is bug 870782 may resolve this, however.
Agreed as it doesn't show up after relanding bug 770840.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870782
(Assignee)

Updated

3 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.