Camera shows black screen when I open the camera app

RESOLVED DUPLICATE of bug 880780

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 880780
5 years ago
5 years ago

People

(Reporter: psdeme, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: keon)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 748406 [details]
Screenshot of the bug

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130510 Firefox/23.0
Build ID: 20130510041606

Steps to reproduce:

I opened the camera app


Actual results:

A black screen appeared with the shot button, the gallery button and the video button in the bottom of the screen.


Expected results:

The camera should have normally opened without this black screen , showing what the camera sees.
(Reporter)

Updated

5 years ago
Whiteboard: keon
(Reporter)

Comment 1

5 years ago
My device is Keon
It is a dupe of Bug 870884.

Comment 3

5 years ago
Same here on Peak. it was working some commits ago. 

Taking photos works fine, and you can see snapshot of what should be displayed when switching between applications. but when the app is focused everything is just black.
(In reply to pancake from comment #3)
> Same here on Peak. it was working some commits ago. 
> 
> Taking photos works fine, and you can see snapshot of what should be
> displayed when switching between applications. but when the app is focused
> everything is just black.

It seems like Bug 894891. It is different from attachment 748406 [details]. It says that the shot button and the video button were disabled. The camera app seems failed to connect to camera hw.
As of today, it is a green rectangle as view finder I have on Keon when opening the camera app.
I believe we should close this as a dupe of 880780.
Dupe of bug 880780. Fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880780
You need to log in before you can comment on or make changes to this bug.