Java Applets treated like image, flicker, lose menu items

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Albert R., Assigned: Terry Noyes)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1+) Gecko/20010620
BuildID:    2001062005

When using the latest MRJ (2.2.5), the java applet on the above mentioned page
exhibits some strange behavior.  When trying to drag the mouse in the applet,
Mozilla keeps treating it like an image, (dragging out of place).  It also
flickers when changing settings.  If you lose the focus on mozilla (switch to a
different app), the drop-down menu items disappear when mozilla has focus again.
 In addition, on the page
http://www.shodor.org/cserd/applets_desk/EfieldView/EfieldView.html, the drop
down menu items are the exact same as the first one, although all 3 should be
different.

Reproducible: Always
Steps to Reproduce:
1. Go to the mentioned pages.
2. On spacepilot, drag the mouse around to get the ship to go somewhere (second
circle from bottom)
3. Give another window the focus, something like simpletext or even another
mozilla window.
4. Give the window running the app focus again.

Actual Results:  Mozilla attempts to drag the applet around as if it was an
image, and the drop down menu items disappear after focus is changed.

Expected Results:  Applet should not be dragged around as image, and drop down
menu items should not disappear.

Comment 1

17 years ago
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI

Comment 2

17 years ago
Terry, can you please look at this?

Thanks,

Ed
Assignee: edburns → tnoyes
(Assignee)

Comment 3

17 years ago
I'll find the check-in for bug 77774 (dup of bug 76982) and see if there is an answer there.

Comment 4

17 years ago
WFM with Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2+) 
Gecko/20010716 on macos 8.5 with MRJ2.2.5, first tried it with mrj 2.2.4 
and could fully reproduce the bug, then download 2.2.5 deleted the old 
one and downloaded mrj plugin from ftp.mozilla.com and restarted 
mozilla.
Reporter could you try with a current build
(Reporter)

Comment 5

17 years ago
using Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2+) Gecko/20010716 and the 
mrj 2.2.5 from apple's website, I still get the pseudo-dragging of java applets 
and the disappearing drop down listboxes still occurs.  I'll try to get an 
attachment in of screenshots of the disappearing listboxes problem.

Comment 6

17 years ago
Yes would be great if you add the attachment, for seeing it working

Comment 7

17 years ago
Sorry for the spam, now i reproduce it with with build id 2001072008 with MRJ2.2.5
while using the applet, Mozilla automatically moves the applet like when you
drag and image from browser to some where.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I too have noticed action as described in Summary above on the mentioned website.

G4-500 1.5 GB system Ram
OS 9.2.2
ATI Rage Pro 128 AGP Graphics Card
Mozilla 0.9.7 Nightly Downloaded Dec 21, 2001

Comment 9

16 years ago
I just checked using Moz 1.0 OS 9.0.4 on one of the gray iMacs, and I'm not
seeing this anymore.  Can someone verify this?
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
No longer seen by reporter.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.