If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks menu doesn't show any bookmarks after landing bug #867343

VERIFIED FIXED in Firefox 23

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED FIXED
4 years ago
2 months ago

People

(Reporter: Virtual, Assigned: mconley)

Tracking

({nightly-community, regression})

23 Branch
Firefox 24
x86_64
Windows 7
nightly-community, regression
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified)

Details

Attachments

(2 attachments)

Like it title. After backing out patches from bug #748894 in bug #867343 bookmarks aren't visible in Bookmarks menu (using Nightly button).
It works fine using  old Bookmarks menu (with ALT key) and in Bookmarks button in toolbar.
Blocks: 867343
Keywords: regression
Created attachment 748549 [details]
no bookmarks in Bookmark menu.png

Comment 2

4 years ago
An error appears in error Console when I click Bookmarks splitmenu.

Error: ReferenceError: BookmarksMenuButton is not defined
Source File: chrome://browser/content/browser.xul
Line: 1

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

4 years ago
Yep, my bad - we didn't take into account https://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-appmenu.inc#222 when renaming BookmarksMenuButton BookmarkingUI.
Assignee: nobody → mconley
(Assignee)

Comment 4

4 years ago
Created attachment 748646 [details] [diff] [review]
Patch v1
Attachment #748646 - Flags: review?(mak77)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED

Updated

4 years ago
Attachment #748646 - Flags: review?(mak77) → review+
while there please also fix the 2 reportError in browser-places that reference BookmarksMenuButton
(Assignee)

Comment 6

4 years ago
Ugh, I pushed without fixing the reportErrors. :/ I'll file a follow-up.

Pushed to mozilla-inbound as https://hg.mozilla.org/integration/mozilla-inbound/rev/01b4b6368014
(Assignee)

Comment 7

4 years ago
Filed follow-up bug 871594 for the reportErrors.
(Assignee)

Updated

4 years ago
status-firefox23: --- → affected
tracking-firefox23: --- → ?
(Assignee)

Comment 8

4 years ago
Comment on attachment 748646 [details] [diff] [review]
Patch v1

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 867343

User impact if declined: Bookmarks menu in AppMenu will not list any bookmarks.

Testing completed (on m-c, etc.): Testing completed on m-c.

Risk to taking this patch (and alternatives if risky): Extremely low risk. We failed to change an instance of BookmarksMenuButton to BookmarkingUI.

String or IDL/UUID changes made by this patch: None.
Attachment #748646 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/01b4b6368014
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
tracking-firefox23: ? → +
status-firefox22: --- → unaffected
Attachment #748646 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4583ecb8f831
status-firefox23: affected → fixed
Status: RESOLVED → VERIFIED
Verified as fixed with Firefox 23 beta 8, build ID: 20130722172257
status-firefox23: fixed → verified
QA Contact: manuela.muntean
Keywords: nightly-community
QA Contact: manuela.muntean → Virtual
You need to log in before you can comment on or make changes to this bug.