Some elements aren't rendered until scroll or other interaction

RESOLVED DUPLICATE of bug 858137

Status

()

Firefox for Android
Toolbar
RESOLVED DUPLICATE of bug 858137
5 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

22 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I can reproduce the bug on some websites with a dropdown menu, if I click on the menu link, the height of the page is updated (because the scrollbar becomes longer), but the menu isn't rendered until I scroll. An affected website is https://addons.mozilla.org/it/android/extensions/?sort=created (the menu that allows you to sort the extensions).

An obvious example of this problem is the attached image. The GIF image is animated only when I zoom and scroll. If I don't do anything, the animation is frozen. While I zoom and scroll, some frames of the animation are rendered.

Sometimes it happens for an entire website, and to force a redraw of the content, I must open the awesomescreen (but I can't find STR for this case).

My device is a Samsung Galaxy S 2 with ICS.
(Reporter)

Comment 1

5 years ago
Same problem for the website in bug 795595. If I start a new game, the pong ball moves only if I zoom/scroll.
(Reporter)

Updated

5 years ago
See Also: → bug 795595
(Reporter)

Updated

5 years ago
Version: Firefox 21 → Firefox 22
(Reporter)

Updated

5 years ago
Blocks: 831243
(Reporter)

Comment 2

5 years ago
Created attachment 751830 [details]
Image
(In reply to Marco Castelluccio [:marco] from comment #0)
> An obvious example of this problem is the attached image. The GIF image is
> animated only when I zoom and scroll. If I don't do anything, the animation
> is frozen. While I zoom and scroll, some frames of the animation are
> rendered.

Is this not a duplicate of bug 858137
(Reporter)

Comment 4

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #3)
> (In reply to Marco Castelluccio [:marco] from comment #0)
> > An obvious example of this problem is the attached image. The GIF image is
> > animated only when I zoom and scroll. If I don't do anything, the animation
> > is frozen. While I zoom and scroll, some frames of the animation are
> > rendered.
> 
> Is this not a duplicate of bug 858137

Probably yes, but the problem isn't restricted to GIF images. See, for example, the URL in bug 795595.
I'm going to dupe this to bug 858137 and expand the scope of that bug to include non-GIF elements too.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858137
(Reporter)

Updated

5 years ago
Depends on: 858137
You need to log in before you can comment on or make changes to this bug.