Bookmark star icon is tiny and duplicated on Retina MacBook Pro

VERIFIED FIXED in Firefox 23

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cpeterson, Assigned: mconley)

Tracking

({regression})

unspecified
Firefox 24
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 748602 [details]
Tiny_stars_screenshot.png

Please see the attached screenshot.

This regression first appeared in Nightly build 2013-05-12. I believe this is a regression from bug 867343.
Assignee: nobody → mconley
Status: NEW → ASSIGNED
@media (min-resolution: 2dppx) {
#star-button {
list-style-image: url("chrome://browser/skin/places/star-icons.png");

should be star-icons@2x.png
Created attachment 748825 [details] [diff] [review]
Patch v1

I don't have a Retina display to try this on, so flying blind here.
Attachment #748825 - Flags: review?(mak77)
I can verify with DOMi on the retina, I should have done that originally...
Comment on attachment 748825 [details] [diff] [review]
Patch v1

Review of attachment 748825 [details] [diff] [review]:
-----------------------------------------------------------------

it works!
Attachment #748825 - Flags: review?(mak77) → review+
tracking-firefox23: --- → ?
Comment on attachment 748825 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 867343

User impact if declined: OSX users with Retina displays will see a very strange grouping of icons where their star button used to be in their URL bar.

Testing completed (on m-c, etc.): mak tested this on a Retina Macbook on m-c.

Risk to taking this patch (and alternatives if risky): None - we simply failed to point some CSS at the right spritesheet.

String or IDL/UUID changes made by this patch: None.
Attachment #748825 - Flags: approval-mozilla-aurora?
Attachment #748825 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/a174d244334e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
tracking-firefox23: ? → +
Matt, can you please verify this is fixed in Firefox 24 and 23 builds?
Keywords: verifyme
QA Contact: mwobensmith
Confirmed issue on m-c 2013-05-12.
Confirmed fixed on FF23b4.
Confirmed fixed on FF24 2013-07-11.
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.