[Dialer] When very long string is saved in contacts, string is represented abnormally in call screen

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::Dialer
P3
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Assigned: mihai)

Tracking

({uiwanted})

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)
uiwanted

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: [TD-27199])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
1. Title : When very long string is saved in contacts, string is represented abnormally in call screen
2. Precondition : contacts >> add contacs
/////////
Name : aa
mobile
phone  : 0102222222
Carrier : dndnwkwwkdndnwkwwkdndnwkwwkdndnwkwwkfjfjfjfjfjfjflwlwlwlwwlwwwwwwdndnwkwwkkkk(very long string)
/////////
Done
3. Tester's Action : aa Outgoing call 
4. Detailed Symptom : string is represented abnormally 
5. Expected :  string is normally represented or "dndnwkwwkdndnwk... "
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduced
8. Gaia Revision : 5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c
9 Personal email id : promise09th@gmail.com
(Reporter)

Comment 1

5 years ago
Created attachment 748656 [details]
String is divided
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Whiteboard: [TD-27199]

Updated

5 years ago
Target Milestone: --- → 1.1 QE2
This is a corner case, but the UX is not attractive here, so ni? on UX team to check that we're meeting specs on contact display in outbound calling.  Also I'm concerned that the screenshot provided shows 'mobile,' in the contact info and not the phone number from that field.  Is this an inconsistency between comment 0 and what was actually entered or do we have another bug here on not showing the phone number - qawanted to try the STR as comment 0 lists them and see if the screenshot is the same.
blocking-b2g: leo? → -
status-b2g18: --- → affected
tracking-b2g18: --- → +
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: qawanted, uiwanted
Whiteboard: [TD-27199] → [TD-27199] c=
(Assignee)

Updated

5 years ago
Assignee: nobody → mihai

Comment 3

5 years ago
Created attachment 748993 [details]
long string for the contact works fine

Comment 4

5 years ago
This issue is not reproducing on both Inari and Unagi. Screen shot attached in the Comment3

Inari Build ID: 20130513070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/50726fbdc25e
Gaia: a503d9a1d0a588f3689243c1ddc0f016ede51b9d

Unagi Build ID: 20130513070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/50726fbdc25e
Gaia: a503d9a1d0a588f3689243c1ddc0f016ede51b9d
Keywords: qawanted
(Reporter)

Comment 5

5 years ago
I think you save string in "Name" section.
But, in this case, save string in "Carrier" section.
Check this please.
Flags: needinfo?

Comment 6

5 years ago
The same issue is still reproducing on Inari and Unagi.

Tested by saving long string in the "Carrier" section.

Inari Build ID: 20130513070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/50726fbdc25e
Gaia: a503d9a1d0a588f3689243c1ddc0f016ede51b9d

Unagi Build ID: 20130513070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/50726fbdc25e
Gaia: a503d9a1d0a588f3689243c1ddc0f016ede51b9d
Flags: needinfo?
Whiteboard: [TD-27199] c= → [TD-27199], u=fx-os-user c=may-20-31 p=1
(Reporter)

Updated

5 years ago
Priority: -- → P3
Whiteboard: [TD-27199], u=fx-os-user c=may-20-31 p=1 → [TD-27199], u=fx-os-user c=scravag-sprint-may-20-31 p=1
Whiteboard: [TD-27199], u=fx-os-user c=scravag-sprint-may-20-31 p=1 → [TD-27199]
Hi Mihail! ;) Are you currently working on this bug or would you like me to take care of it? I know where to include the needed changes :-) If you would like me to take care of it, please do not hesitate to directly assign it to me. Thanks!
Flags: needinfo?(mihai)
Hi gtorodelvalle, I am planning to work on it this evening (had some other patches in my queue by now). Thanks for asking, and sorry I'm not letting it go :)
Flags: needinfo?(mihai)
Created attachment 750131 [details]
Pull Request #9803 - Truncate additional contact info

Simple CSS fix when displaying additional contact info.
Attachment #750131 - Flags: review?(etienne)
Comment on attachment 750131 [details]
Pull Request #9803 - Truncate additional contact info

thanks!
Attachment #750131 - Flags: review?(etienne) → review+

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 11

5 years ago
Reassigning from general UX to Francis, for the quick UI check in comment 2. Looks like the rest is done.
Flags: needinfo?(fdjabri)
Thanks Etienne! Landed on master:
https://github.com/mozilla-b2g/gaia/commit/c7f7636510a3a62e21d81107fd4e3ba7bb501854

Regarding the UI question from comment 2, I would suggest a follow-up bug to be filed if instead of 'mobile' the phone number should be shown. I would be more than happy to take it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 750131 [details]
Pull Request #9803 - Truncate additional contact info

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): OnCall screen > additional info
User impact if declined: Low (if carrier name is longer then the screen width it is not truncated)
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: No
Attachment #750131 - Flags: approval-gaia-v1?
Comment on attachment 750131 [details]
Pull Request #9803 - Truncate additional contact info

Minor width change and low risk - approving.
Attachment #750131 - Flags: approval-gaia-v1? → approval-gaia-v1+
Uplifted c7f7636510a3a62e21d81107fd4e3ba7bb501854 to:
v1-train: 8929c1b60f84fd0bd06510bbb477a6c7762d9747
status-b2g18: affected → fixed

Updated

4 years ago
Flags: needinfo?(fdjabri)
You need to log in before you can comment on or make changes to this bug.