[Email] Long email id bubble on composer is out of composer screen

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::E-Mail
P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: Leo)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

(Whiteboard: [TD-26515])

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

5 years ago
1. Title : Long email id bubble on composer is out of composer screen
2. Precondition : Email should be working 
3. Tester's Action:  Launch Email -> composer -> To field -> enter long email id till the text goes left -> add ; at the end.
4. Detailed Symptom (ENG.) : 
a. Email address bubble is cut and out of screen.
b. This issue also reproduces when we create a contact with long email id and in view contact, select email id
c. Issue reproduces in To, cc and bcc fields.
5. Expected :Email id should be shown with properly.
6.Reproducibility: Y
           1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 393b3f57822ae0f34055c6a6060f1433136bafa0
9.Personal email id:  psingapati@gmail.com

Comment 1

5 years ago
Created attachment 748687 [details]
Long EMail id bubble is cut

Long email id bubble is cut.

Updated

5 years ago
Target Milestone: --- → 1.1 QE2
Assignee: nobody → mihai
(Assignee)

Updated

5 years ago
Priority: -- → P2

Comment 2

5 years ago
Created attachment 749248 [details]
Pull Request pointer

This issue is reported in composer screen. But .msg-peep-bubble is used for composer peep bubble since it has all the styling.
So, Set Max width to -moz-available to make sure all the peep bubbles take the required width and set text-overflow: ellipsis;

Please review it.
Attachment #749248 - Flags: review?(bugmail)

Comment 3

5 years ago
Hi Mihai,
I have uploaded patch to this issue.
Please un assign yourself, I will take it.

Thanks.
Flags: needinfo?(mihai)
(In reply to psingapati from comment #3)
> Hi Mihai,
> I have uploaded patch to this issue.
> Please un assign yourself, I will take it.
> 
> Thanks.

Sure, it's all yours :)
Assignee: mihai → psingapati
Flags: needinfo?(mihai)

Updated

5 years ago
Assignee: psingapati → leo.bugzilla.gaia
Attachment #749248 - Attachment mime type: text/plain → text/html
Comment on attachment 749248 [details]
Pull Request pointer

Looks good! r=asuth.  Please use rebase to put the bug number explicitly in the commit message rather than just in the pull request and then you can merge that.
Attachment #749248 - Flags: review?(bugmail) → review+
Comment on attachment 749248 [details]
Pull Request pointer

Whoops, have to take the r=asuth back. This regresses the message reader's bubbles and causes them to become vertically unaligned with their labels.  Probably for the same reason the attachment patch has trouble because of the filename and its overflow stuff.

Please look into that.
Attachment #749248 - Flags: review+ → review-

Comment 7

5 years ago
Created attachment 749735 [details]
Pull Request pointer

I have tried the below two approaches

1) having common peep-bubble in mail.css
but ended up with many regressions, may be I did in wrong way.
so I left that approach

2) Tried with separate text-overflow:ellipsis; styling for .cmp-peep-bubble and added this class to the peep node along with .msg-peep-bubble.

I tested thoroughly in both composer and message reader screens.
If this approach is okay , please accept the patch.

Thanks.
Attachment #748687 - Attachment is obsolete: true
Attachment #749735 - Flags: review?(bugmail)
Attachment #749735 - Attachment mime type: text/plain → text/html
Comment on attachment 749735 [details]
Pull Request pointer

I would still prefer the cleanup, but I am aware that's a more major undertaking because of the places where the code explicitly uses the classes for identification purposes.

r=asuth, but please fix the commit so that it has a real author; right now it's a very verbose build id.  While there, if you could also fix up the commit message too.  What I usually do is just copy and paste the bug number and title from the top of the bugzilla page.  So in this case, it would be:

Bug 871449 - [Email] Long email id bubble on composer is out of composer screen

The key things to get, though, are the bug number with "Bug " in front of it for regexes we use, and the [Email] bit which helps make it more obvious in the git log what app was being modified.

You can merge once that's fixed.  Thanks!
Attachment #749735 - Flags: review?(bugmail) → review+

Comment 9

5 years ago
Please request approval-gaia-v1 to land to v1.1, since this is not a blocker. Thanks!
blocking-b2g: --- → -
tracking-b2g18: --- → +

Comment 10

5 years ago
Created attachment 750853 [details]
Pull Request pointer

Added New PR with proper commit message and author.
Attachment #749248 - Attachment is obsolete: true
Attachment #749735 - Attachment is obsolete: true
Attachment #750853 - Flags: review?(bugmail)
Attachment #750853 - Attachment mime type: text/plain → text/html
Attachment #750853 - Flags: review?(bugmail) → review+
landed on gaia/master:
https://github.com/mozilla-b2g/gaia/pull/9831
https://github.com/mozilla-b2g/gaia/commit/dff274b6689fe444dd71a017e2ccea4bfeb4b88f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.