Image and Javascript EN/Disable options missing in Nightly Build on OSX

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bernhard.bezdek, Unassigned)

Tracking

23 Branch
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 748708 [details]
Bildschirmfoto 2013-05-13 um 11.00.46.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130512 Firefox/23.0
Build ID: 20130512030908

Steps to reproduce:

On the last Nightly Version I disabled "load images" inside the Content Settings.
Now after an update the option for dis/enabling images is missing.


Actual results:

So images aren't loaded because the setting seems to be disabled anyway.


Expected results:

I think the option is just missing and if not so reset any setting back to the regualray default value.

Comment 1

5 years ago
See:
Gijs Kruitbosch — Bug 851701, bug 851702 - reset image/js loading preferences, r=gavin
Blocks: 851701, 851702
Component: Untriaged → Preferences

Comment 2

5 years ago
(In reply to bernhard.bezdek from comment #2)
> Created attachment 748708 [details]
> Bildschirmfoto 2013-05-13 um 11.00.46.png
> 
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0)
> Gecko/20130512 Firefox/23.0
> Build ID: 20130512030908
> 
> Steps to reproduce:
> 
> On the last Nightly Version I disabled "load images" inside the Content
> Settings.
> Now after an update the option for dis/enabling images is missing.
> 
> 
> Actual results:
> 
> So images aren't loaded because the setting seems to be disabled anyway.
> 
> 
> Expected results:
> 
> I think the option is just missing and if not so reset any setting back to
> the regualray default value.

There is migration code to reset the setting. I suspect your profile was used on a newer version of Firefox (Nightly, UX, whatever) and went back to an older version for some reason. Now when you updated again, the migration code wouldn't have run again (because your profile stores whether it migrated to a newer version already or not, and doesn't migrate backwards or anything like that). Is that possible?

Can you check and tell me the values of the following prefs in about:config:

permissions.default.image
browser.migration.version

If you are not actually talking about the global preference, but about your per-site lists, we opted not to reset this because people may value their lists. You can still manage them by using an add-on, eg.: https://addons.mozilla.org/en-US/firefox/addon/settingsanity/ .

Thank you! :-)
Flags: needinfo?(bernhard.bezdek)
(Reporter)

Comment 3

5 years ago
I talk about the global preference called by CMD + ,.
Flags: needinfo?(bernhard.bezdek)
(Reporter)

Comment 4

5 years ago
I was able to reenable it via enabling the checkbox in Firefox Webbrowser and switch back to Nightliy build

Comment 5

5 years ago
OK. Then I assume the original migration probably worked fine, too. Thank you for letting us know!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.