User can't install a purchased App later

RESOLVED DUPLICATE of bug 834954

Status

Marketplace
Consumer Pages
RESOLVED DUPLICATE of bug 834954
5 years ago
5 years ago

People

(Reporter: rafael.medola, Assigned: basta)

Tracking

({regression})

Other
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 748722 [details]
screenshot

Steps to reproduce:

1- Log in to MP;

2- Search for a paid App;

3- Buy it;

4- Skip the installation (cancel it).

Expected behavior:

If the user search for the same App, the button with the price will be changed for a Install button.
Resuming: The user can't buy the same App twice, if the install is skipped the user can do it later, but never buy again.


Observed behavior:

If the user skips the installation for a purchased App, it can't be done later.
The price is presented again and pushing to buy, the MP does not take any action.
The install is not available even in the User's app history.
(Reporter)

Comment 1

5 years ago
Created attachment 748753 [details]
log file
Component: Payments/Refunds → Consumer Pages

Updated

5 years ago
Keywords: regression
Blocks: 859511
This sounds like maybe a dupe of bug 871006
Assignee: nobody → mattbasta
Basta, did bug 871006 fix this?
(Assignee)

Comment 4

5 years ago
It might, I don't know. I wasn't able to reproduce this bug. The new implicit cache rewrite might have fixed the issue, though.
(Reporter)

Comment 5

5 years ago
Hi guys, if skip the installation screen right purchased the App, its install fails (no action) trying to do that from "My Apps".
Searching again for the same App, the price will be available for purchase again, clicking on that nothing happens too.
(Assignee)

Comment 6

5 years ago
Rafael: can you create a screencast of the issue? I'm not sure I understand what you mean.

Comment 7

5 years ago
Created attachment 758398 [details]
Step by Step

Comment 8

5 years ago
Matt Basta, the bug was updated as required. Please let me know if you need something else.
(Assignee)

Comment 9

5 years ago
Does this happen for all apps or just some?

Comment 10

5 years ago
For all apps
(Assignee)

Updated

5 years ago
Duplicate of this bug: 871488
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834954
You need to log in before you can comment on or make changes to this bug.