User can buy the same paid App twice

RESOLVED DUPLICATE of bug 871006

Status

Marketplace
Payments/Refunds
RESOLVED DUPLICATE of bug 871006
5 years ago
5 years ago

People

(Reporter: rafael.medola, Unassigned)

Tracking

Other
Gonk (Firefox OS)
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:

1- Log in to MP;

2- Search for a paid App;

3- Buy it;

4- Skip the installation;

5- Search for the same App;

6- Click to buy it again.


Expected behavior:

After buy and skip the installation, the price button is changed for an "install" button.
So the user can install the bought App later.

Observed behavior:

After buy and skip the installation, the price button is still available giving the change to the user buy it again.
If the user try to buy it twice, the MP has no action and the button changes to "purchasing" and no action is taken.
(Reporter)

Comment 1

5 years ago
Created attachment 748755 [details]
log file

The bug can be observed at the end of this LOGS.
This log was previously grabbed for another bug, but the bad behavior is observed for this bug too.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871006
You need to log in before you can comment on or make changes to this bug.