[STK] don't send SMS from STK app

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: frsela, Assigned: pgravel)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: TEF: 44776)

Attachments

(1 attachment)

_______________________________________________________________________________
A.- Overview Description (technical background, concise explanation of the bug):

The DuT does not receive the expected SMS.
________________________________________________________________________________
B.- Steps to Reproduce (initial conditions, required resources, step by step instructions to reproduce):

1. Turn the DuT on with a SIM with menu ACTIVA.
2. Go to STK menu and select "Mensajes" item
3. Select "Chat Movistar".
4. Select "Buscar canal"
5. Select "Todos".
________________________________________________________________________________
C.- Actual Result (current bad behaviour that is reported as a bug):

The DuT displays "Enviando mensaje." "Mensaje enviado" but the expected incoming SMS with the requested information is not received.
________________________________________________________________________________
D.- Expected Result (correct behaviour wished):

After the SMS is sent from the DuT asking for the information, a new SMS will be received with the requested information.
________________________________________________________________________________
E.- Additional information (possible causes suspected, hints to debug, related bugs):
It's seems a regression, I'm analyzing it. I'll inform as soon as I have more info.
blocking-b2g: --- → tef?
Whiteboard: TEF: 44776
Created attachment 748849 [details]
RIL and UI logs

On 05-13 17:36:43.912 "Todos" option is selected. This options should sent a SMS but its not sent.

STK respond with "Enviando mensaje" (sending message) display text command.

I suspect is a RIL/Gecko issue.
Flags: needinfo?(allstars.chh)

Comment 3

5 years ago
Were you able to confirm whether or not this was a regression?
Flags: needinfo?(frsela)

Updated

5 years ago
blocking-b2g: tef? → tef+
What device/build is this from.  The logs from attachment 748849 [details] are clearly not from a commercial build.

Comment 5

5 years ago
Fernando, the logs are with Moz RIL, could you please try with commercial RIL?

Updated

5 years ago
Assignee: nobody → pgravel
(In reply to Michael Vines [:m1] [:evilmachines] from comment #4)
> What device/build is this from.  The logs from attachment 748849 [details]
> are clearly not from a commercial build.

It has been reported by TEF certification team (they use commercial build). I reproduced it yesterday afternoon with my working device.

Today I'll investigate more on this issue + with commercial RIL.

I created the bug in order to inform and track it ;)

BTW, Do you've an QC some STK tests which sents SMS to re-test it? (in order to avoid local service issues)
Flags: needinfo?(frsela) → needinfo?(anshulj)

Comment 7

5 years ago
Fernando, there could be a GCF TC for the same but I will have to hunt it down. If could please provide me the PDU for the received SMS it will be much faster for us to debug the issue.
Flags: needinfo?(anshulj)
(In reply to Fernando R. Sela [:frsela] from comment #2)
> On 05-13 17:36:43.912 "Todos" option is selected. This options should sent a
> SMS but its not sent.
> 
> STK respond with "Enviando mensaje" (sending message) display text command.
> 
> I suspect is a RIL/Gecko issue.

The SMS Sending is done in modem, RIL only passes the notification to Gaia.
I think this is related to modem.
Flags: needinfo?(allstars.chh)
Finnaly appears that the issue is in the service since it's failing on other devices.

Thanks for your time. Anyway will be great to test if SMS is working on commercial device.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.