Closed Bug 871579 Opened 11 years ago Closed 11 years ago

Payments failed with "User does not exist" error in roaming

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vcarciu, Assigned: keir)

References

Details

Attachments

(2 files)

Attached image Error screenshot
steps to reproduce:
1.Using a Movistar SIM from Romania, be sure that roaming and carrier data traffic are enabled
2.Open Marketplace Stage app on your Unagi device and log in
3.Search for a paid app and start the purchase process
4.Enter the payments PIN and then BUY button in order to purchase via carrier billing

expected behavior:
App is successfully purchased

observed behavior:
Payment is failed with "User does not exist" error

Please see attached screenshot with exact error

NOTES:
Not reproducible from Spain
Attached file Adding logs...
Assignee: nobody → keir
Reviewed in Spain:
*Wifi case: Spain said the MSISDN is not a movistar one. Could you confirm?

*MobileID: token lifetime was too short. Reconfiguring.
The bug is not reproducible anymore but I can confirm that I used a Movistar SIM
This was due to mobileid validity being reduced to 24, Steve will validate what this will be in production
Flags: needinfo?(jorgev)
Victor, is it working for your SIM now?

Regarding validity, we need info from Bango to configure the token validity. As we restricted it to 24h for the testing week.

I think it should be 1 month, but I needed to confirm it.
Flags: needinfo?(jorgev)
(In reply to Jorge Villa from comment #5)
> Victor, is it working for your SIM now?
> 
> Regarding validity, we need info from Bango to configure the token validity.
> As we restricted it to 24h for the testing week.
> 
> I think it should be 1 month, but I needed to confirm it.

Yes it is working now using same Movistar SIM
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Marking bug as verified based on the discussion from above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: