TB doesn't delete messages from server w/POP3

RESOLVED INVALID

Status

Thunderbird
Untriaged
--
major
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Nikos Balkanas, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gmail settings, URL)

(Reporter)

Description

5 years ago
User Agent: Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.13

Steps to reproduce:

I use latest TB to interface with my gmail over POP3. If I knew that it was so buggy, I wouldn't use it in the first place. I want to delete messages from my server, when I download them to TB. I use Windows x64.


Actual results:

Contrary to what I have read (maybe was working in previous versions and broke since) I leave "Server Settings->Leave messages on server" unchecked and I get:
1) Mail is deleted from server, once I download it to TB
2) Mail not deleted from server when I delete it from TB and empty its trash
3) Mail not deleted from TB if I delete it from server

2 & 3 are just gravy that I don't really need. (1) is extremely important.


Expected results:

Mail should be deleted from server. Now, if new mail arrives, and I don't want it, I have to delete it from 2 places, which defeats the whole purpose of using TB...
(Reporter)

Updated

5 years ago
Severity: normal → major
(Reporter)

Comment 1

5 years ago
Correction:
1) Mail is NOT deleted from server, once I download it to TB.

Sorry for the typo.

Comment 2

5 years ago
It looks like deleting messages is optional on the gmail side.
Please check your settings "forwarding and pop" by logging into your gmail account with a browser.
(Reporter)

Comment 3

5 years ago
Yes!!! Absolutely right.
I feel embarrassed for not finding it out myself, but 2 days of posting this question to the forum, didn't get any responses.
Just to summarize, this setting is under:

"<Gear>->Settings->Forwarding and IMAP->2. When messages are accessed with POP"

I take back all the bad words I said about TB. TB rocks!

Thank you,
Nikos
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 4

5 years ago
(In reply to Nikos Balkanas from comment #3)
> Yes!!! Absolutely right.
> I feel embarrassed for not finding it out myself, but 2 days of posting this
> question to the forum, didn't get any responses.

URL to forum post?
Flags: needinfo?(nbalkanas)
Whiteboard: gmail settings
(Reporter)

Comment 5

5 years ago
Sure, here it is:

http://forums.mozillazine.org/viewtopic.php?f=39&t=2703623

Mind my asking why do you need it?
Flags: needinfo?(nbalkanas)

Comment 6

5 years ago
(In reply to Nikos Balkanas from comment #5)
> Sure, here it is:
> 
> http://forums.mozillazine.org/viewtopic.php?f=39&t=2703623
> 
> Mind my asking why do you need it?

It is nice to have a cross reference
You need to log in before you can comment on or make changes to this bug.