Copy & paste of images changes image & link URL from relative to absolute

RESOLVED DUPLICATE of bug 805359

Status

RESOLVED DUPLICATE of bug 805359
6 years ago
6 years ago

People

(Reporter: nik_bull, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Using Composer in 'Normal' or 'Preview' view, I copied & pasted an image within the same document.  


Actual results:

Upon uploading the page I discover both image & link broken.  Upon examining the pasted image I discover that both the image URL & Link URL have changed from relative to absolute.  This makes the copy & paste feature effectively non-functional.


Expected results:

The URL relativity status should be maintained during copy & pasting, ie. relative URL's should stay relative, absolute URL's should remain absolute.  I see many similar bugs involving URL's but not this specific problem & I don't think a debate as to whether relativity should be changed is valid.  Just copy as is, surely that's what copy means?

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805359
You need to log in before you can comment on or make changes to this bug.