bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Create "WebFaker" tool for use in Dev/Testing in our other Tools

RESOLVED FIXED

Status

Webmaker
webmaker.org
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mjschranz, Assigned: humph)

Tracking

Details

(Whiteboard: s=2013w20)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Popcorn Maker and Thimble depend on the MakeAPI and Login/SSO to work properly. Each tool has their own set of tests that currently require devs to run their own instances in order to run their own tests. There also is a reliance on running their own tools locally to prevent issues with potential collisions.

The goal here is to have a toolset that projects can use to help emulate external dependencies while reliably being able to test their own work.
Whiteboard: s=2013w20
(Assignee)

Updated

5 years ago
Blocks: 871626
No longer depends on: 871626
(Reporter)

Updated

5 years ago
Depends on: 872340
(Assignee)

Comment 1

5 years ago
Created attachment 750585 [details]
https://github.com/humphd/webfaker

Published to npm as webfaker@0.0.1
Attachment #750585 - Flags: review?(schranz.m)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 872340
(Assignee)

Comment 3

5 years ago
Updated to webfaker@0.0.2
(Reporter)

Comment 4

5 years ago
This is good to be closed from what I can tell. I have Popcorn Makers tests running just fine with this tool.
(Assignee)

Comment 5

5 years ago
Cool, we'll file bugs against it going forward then.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Attachment #750585 - Flags: review?(schranz.m)
You need to log in before you can comment on or make changes to this bug.