If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

select elements with CSS width set and overflow: hidden have unecessary scrollbars

RESOLVED DUPLICATE of bug 203645

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 203645
17 years ago
14 years ago

People

(Reporter: Martin Honnen, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
With the following

<select style="width: 100px; hidden;">
<option>Kibology for all. All for Kibology. Kibology for all. All for
Kibology.</option>
</select>
<br />
<select style="width: 100px; hidden;" size="2">
<option>Kibology for all. All for Kibology. Kibology for all. All for
Kibology.</option>
</select>

I get unnecessary scrollbars. The first single line select shows a vertical
scrollbar when opened (arrow clicked) although there is only one option. This
option should be displayed in its full height without any (need for a) scrollbar.
The second multiple line select shows both vertical and horizontal scrollbars.
There shouldn't be horizontal scrollbars as overflow is set to hidden, and I
don't understand why there is is a vertical scrollbar, the size is set to 2 and
there is only one option. It seems that first a height for size two is choosen,
then the horizontal scrollbar is put in cutting of from the height which makes
the vertical scrollbar necessary (but that is only my guess).
(Reporter)

Comment 1

17 years ago
Created attachment 39565 [details]
bug demo (open first select to see scrollbar, second select shows scrollbars anyway)

Updated

17 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

16 years ago
Somebody broke something, it used to work a lot better than this.
Status: NEW → ASSIGNED
Priority: -- → P1
(Assignee)

Comment 3

16 years ago
Moving to Future
Target Milestone: mozilla1.0 → Future
(Assignee)

Updated

16 years ago
Priority: P1 → P3

Comment 4

14 years ago
Martin, Is this still an issue?
(Reporter)

Comment 5

14 years ago
Created attachment 142585 [details]
new test case (as previous one doesn't seem to have correct CSS syntax)

To be able to answer the request whether the problem still exists I have looked
at the previous test case again and found that the CSS used in there is not
even syntactically correct. 
I have written a new test case which I am uploading now, in that test case the
horizontal scrollbars are gone when tested with Mozilla 1.7a (Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219), only the second
select still has a vertical scrollbar which it doesn't need as there is only
one option in a select with size set to two.
Attachment #39565 - Attachment is obsolete: true

Comment 6

14 years ago
Martin, the second issue you mention is bug 203645. I suggest duping this one to
that one since that one got a bit of attention.
(Reporter)

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 203645 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.