*P1 - [basket] [Newsletter] new email signups are not working consistently - text isn't working at all.

RESOLVED FIXED

Status

www.mozilla.org
Newsletters
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jessilyn Davis (Maternity Leave), Assigned: pmac)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to replicate:

1) go to any newsletter signup (ie: www.mozilla.org/newsletter)
2) Sign up with an email address that does not exist in Exact Target and select text email format
3) Submit

Error found:
Welcome email is not sent, and subscriber is not added to "Master_Subscribers"

Expected behavior:
For subscriber to be added to "Master_Subscribers" and the right text welcome email is sent.
(Reporter)

Updated

5 years ago
Blocks: 859564
(Reporter)

Comment 1

5 years ago
Looks like text email signups aren't working at all - and HTML signups are working sporadically.

Steps to replicate:

1) Go to: https://www.mozilla.org/en-US/newsletter/
2) Sign up with a brand new email address that has never been in Exact Target
3) Look for welcome email/check Exact Target's Master_Subscribers


Error found:
Contact was not added


NOTES: 
1) Winston's new address did work, but my variation of @gmail.com address did not.
2) Our subscription numbers did go up over the weekend, but the daily counts were less than half of what they normally are (5k instead of 13k)


Are we getting errors from our calls to ET?
What's up?
Assignee: malexis → pmac
Summary: P1 - [basket] [Newsletter] new Text email format signups are not working → *P1 - [basket] [Newsletter] new email signups are not working consistently - text isn't working at all.

Comment 2

5 years ago
Commits pushed to master at https://github.com/mozilla/basket

https://github.com/mozilla/basket/commit/088b3072f5d30603ee512be13d9ae293b5074334
Bug 871764: Fix errors causing subscriptions to fail.

https://github.com/mozilla/basket/commit/aec5292e5ca49ae7c4e2687b4b2d7d58f6611e22
Merge pull request #41 from pmclanahan/fix-error-on-get-user-data-bug-871764

Bug 871764: Fix errors causing subscriptions to fail.
The issue seems to have been with our recent fix to avoid updating the date for a flag if the user was already subscribed. This was throwing errors if our request for data from exact target was failing. One possible reason for this failure is that the user wasn't yet in exact target because they were signing up for the first time.

I'm now in the process of getting the data from the failed calls from sentry (our error collection service) and resending them to basket.

My fix was pushed to prod and appears to have fixed this issue. Please reopen if you see evidence to the contrary.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.