Crash viewing a source of an expired news article

VERIFIED DUPLICATE of bug 77441

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 77441
17 years ago
10 years ago

People

(Reporter: marina, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
**** observed with 2001-06-21 build ****
Steps to repro:
- go to the newsgroup (relcom.cinema)( crashes with ascii and non-ascii articles)
- select an expired article;
- go View|message source;
//observe the crash
stack to follow
(Reporter)

Comment 1

17 years ago
here is a stack:
nsReadingIterator::normalize_forward [..\..\dist\include\nsStringIterator.h,
line 366]
nsReadingIterator::advance [..\..\dist\include\nsStringIterator.h, line 176]
copy_string [..\..\dist\include\nsAlgorithm.h, line 81]
Distance [d:\builds\seamonkey\mozilla\string\src\nsReadableUtils.cpp, line 100]
nsScanner::RewindToMark
[d:\builds\seamonkey\mozilla\htmlparser\src\nsScanner.cpp, line 231]
nsParser::Tokenize [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2629]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2053]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2521]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 238]
nsMimeBaseEmitter::Complete
[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeBaseEmitter.cpp,
line 866]
nsStreamConverter::OnStopRequest
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 1005]
nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 255]
nsStreamListenerTee::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 25]
nsNNTPProtocol::CleanupAfterRunningUrl
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNNTPProtocol.cpp, line 5360]
nsNNTPProtocol::ProcessProtocolState
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNNTPProtocol.cpp, line 5306]
nsMsgProtocol::OnDataAvailable
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgProtocol.cpp, line 243]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 185]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 419]
netscp6.exe + 0x16ca (0x004016ca)
netscp6.exe + 0x11b8 (0x004011b8)
netscp6.exe + 0x2eb9 (0x00402eb9)
KERNEL32.DLL + 0x7903 (0x77e87903) 
This seems like a dup of an older bug you've filed, bug 77441
(Reporter)

Comment 3

17 years ago
yes, it looks like in the bug #77441 we changed summary to "source of an expired
article is blank" ( because it didn't crash for a while) so we either change the
summary of 77441 back to "Crash" or leave this one?
I just changed the summary of the old one, since the fix for either bug should
fix both.

*** This bug has been marked as a duplicate of 77441 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
same call stack, even, verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.