Unable to use Sun's Java plugin w/ Mozilla 2001062011

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
VERIFIED FIXED
17 years ago
8 years ago

People

(Reporter: sbchodogg, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have a RedHat 7.1 box with a Mozilla .9.1+ build.  I have tried installing the
Java plugin both by running Mozilla as root and using the auto-installer by
visiting sun.java.com and by installing Sun's JDK and putting a link to the JRE
plugin in the proper directory.  My /usr/lib/mozilla/plugin directory is as follows:

lrwxrwxrwx    1 root     root           61 Jun 21 18:18 libjavaplugin_oji.so ->
/usr/java/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so
-rwxr-xr-x    1 root     root        19384 Jun 20 13:17 libnullplugin.so

I can run the JVM and appletviewer fine on the command line.  Mozilla runs fine
but does not load the Java plugin.  about:plugins only lists the null plugin.

File name: /usr/lib/mozilla/plugins/libnullplugin.so
The default plugin handles plugin data for mimetypes and extensions that are not
specified and facilitates downloading of new plugins.

Mime Type Description Suffixes Enabled
*    All types        .*       Yes

I've done this fine before using earlier versions of Mozilla on RedHat 7.0.  Any
ideas as to what is going wrong?

Thanks,
Scott

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 84093 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I don't think this is a duplicate of 84093
.  Mozilla doesn't hang on Java pages for me, it never loads the plugin and
keeps trying to install it every time a I go to Java page.  Its also not the
same as the LD_ASSUME_KERNEL problem as I tried that.  I can get the browser to
even see the plugin even though its in the directory.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
Scott:
     Can you use other plugin like flashplayer or realplayer? If you can not 
use, I think you don't have libXt.so which is usefule to load the plugins.

   
(Reporter)

Comment 4

17 years ago
I cannot load other plugins such as flashplayer now that you mention it.  I have
libXt, though:

-rw-r--r--    1 root     root       410742 Mar 30 21:46 libXt.a
lrwxrwxrwx    1 root     root           12 Jun 20 23:55 libXt.so ->
libXt.so.6.0lrwxrwxrwx    1 root     root           12 Jun 20 17:12 libXt.so.6
-> libXt.so.6.0
-rwxr-xr-x    1 root     root       308432 Mar 30 21:51 libXt.so.6.0

are in /usr/X11R6/lib, which is listed in /etc/ld.so.conf
(Reporter)

Comment 5

17 years ago
You were correct.  It was libXt.  I didn't realize I had only installed it since
I had these plugin problems.  Thanks very much for the help.  Perhaps Mozilla
should report an error when loading plugins if libXt is not found?  At least on
the about:plugins page?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.