Closed Bug 871944 Opened 7 years ago Closed 7 years ago

B2G MMS: should move MMS codes from dom/mms to dom/mobilemessage

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla24
blocking-b2g -
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix

People

(Reporter: airpingu, Assigned: vicamo)

References

Details

(Whiteboard: [fixed-in-birch])

Attachments

(2 files)

We should move MMS codes from dom/mms to dom/mobilemessage which collects all the messaging codes including SMS and MMS. This is nothing but a minor issue.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #2)
> Created attachment 751627 [details] [diff] [review]

Some files are `hg mv`ed and are hidden by bugzilla. You might need to download the patch for those parts. :)
Comment on attachment 751627 [details] [diff] [review]
patch

Review of attachment 751627 [details] [diff] [review]:
-----------------------------------------------------------------

Looks nice. Please make sure the MMS directory completely disappears after the patch is applied. Btw, this one might be worth uplifting to b2g18 to avoid inconvenient maintenance in the future. I'd suggest ask the approval first and then land it to central and b2g18 at the same time.
Attachment #751627 - Flags: review?(gene.lian) → review+
Nominate for leo+ because MMS will be shipped on v1.1 and it will be more convenient to have synchronized directory structure with m-c.
blocking-b2g: --- → leo?
https://hg.mozilla.org/mozilla-central/rev/211b56200401
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Please nominate for approval-mozilla-b2g18, since this is not critical.
blocking-b2g: leo? → -
Comment on attachment 751627 [details] [diff] [review]
patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no.
User impact if declined: no.
Testing completed: yes.
Risk to taking this patch (and alternatives if risky): no.
String or UUID changes made by this patch: no.

This patch is aimed for moving the MMS codes to a better directory. That is, mobilemessage/. I don't think we would have any risk to do so. However, it would make the followers more convenient to land MMS codes to b2g18 if they can be in the same file path.
Attachment #751627 - Flags: approval-mozilla-b2g18?
Attachment #751627 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
You'll be shocked to hear I'm sure that this doesn't apply to b2g18.
not at all. We'll handle that, thank you :)
You need to log in before you can comment on or make changes to this bug.