link doesnt appear as href in 6.1 but appears so in 4.x

VERIFIED INVALID

Status

Tech Evangelism Graveyard
English US
VERIFIED INVALID
17 years ago
3 years ago

People

(Reporter: varada, Assigned: bc)

Tracking

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

17 years ago
link doesnt appear as href in 6.1 but appears so in 4.x

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → Evangelism
Resolution: --- → INVALID

Comment 1

17 years ago
sorry, the link's bad (xml).

<a href="foo"/> == <a href="foo"></a>

Comment 2

17 years ago
Verifying invalid, since evangilism bugs need to specify a URL which has the
problem.
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
This a valid bug. The original URL requires a specific login.
I can be easily reproduced by creating a HTML file with the following
contents
<HTML>
<body>
<a href="http://www.news.com"/>News
</body>
</HTML>
and opening it with the Mozilla browser.
Netscape 4.7 and IE show a page with a hyperlink "News" to www.news.com.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 4

17 years ago
.
Assignee: asa → bclary
Status: REOPENED → NEW
QA Contact: doronr → zach
OK.  The syntax <a href="whatever"/> is the same as <a href="whatever"></a>

So the "News" is _not_ inside the anchor.  IE and 4.7 both do not do empty tags 
ending with "/" properly, but that's their bug not ours.

Please update the URL field with a URL to be evangelized or resolve this invalid.
Whiteboard: DUPEME

Comment 6

17 years ago
Not too much support here to be less forgiving to compete with
commercial browsers and capture market. Only the owner can resolve
this back to invalid.
2 cases:

1) Strict mode.  Being "forgiving" would lead us to misrender perfectly correct
HTML as IE and others do.

2) Quirks mode.  We would need major parser modifications to support this in
quirks mode only

See bug 84633 for what the parser people think of this bug.  I recommend that
this be marked duplicate of bug 84633

Marking duplicate, since this _has_ been discussed before
(Assignee)

Comment 8

17 years ago
Is this filed against a site? Evangelism bugs must be filed against a site
somewhere so we can evangelize them. If this is a news.com problem, please
reopen and give me a URL. ( I found a use for INVALID Evangelism bugs after all)
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Assignee)

Comment 9

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 10

16 years ago
Verified
2002040608/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.