Closed Bug 872047 Opened 6 years ago Closed 4 months ago

override.ini read from the wrong place after splitting app and platform resources

Categories

(Firefox :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mkaply, Unassigned)

References

Details

So there's one other file we forgot about in this move, override.ini.

override.ini is used to allow people to turn off the profile migrator.

It got moved to browser as well, but I believe it belongs in the top level directory (the same location as application.ini).

Since this won't make the FF21 train, I'm wondering if we could allow it in both places.

If we can't, I still think we should move it back so it is correct for the ESR 24
Blocks: metro-build
override.ini is very closely tied to the specific application.ini data being started, and I think it should probably still live in the browser/ subdirectory.
application.ini doesn't live in the browser directory, it lives in the top level directory.

So if override.ini is overriding data in the application.ini, it would make sense that it would live in the same directory.
ok, I remember that being an unfortunate side effect of releng dependencies.

The actual data in application.ini is different for Metro and desktop Firefox. We don't actually read the application.ini file at all (it is compiled in). And I believe that the override data will probably also need to be separate.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> ok, I remember that being an unfortunate side effect of releng dependencies.

Indeed ; we only keep application.ini there because the scripts used on our test infrastructure reads it there. Firefox itself doesn't use it.
But if someone were going to put an override.ini down, the logical place to put it would be "the same place as application.ini"

The only thing that is actually read from override.ini is EnableProfileMigrator

https://mxr.mozilla.org/mozilla-central/source/toolkit/xre/nsAppRunner.cpp#3721

Is the profile migrator used on Metro?

Do you see a world where we actually use the override.ini for interesting stuff? It's been asked for:

https://bugzilla.mozilla.org/show_bug.cgi?id=application.ini

But no one seems interested.

I'm just trying to prevent more pain for the next ESR...
Hrm, I thought we fixed things so that override.ini could have all the same values as application.ini. I certainly had a patch queue to do that at some point in the past! ;-)

It's silly for a file named override.ini to contain just this single option.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> Hrm, I thought we fixed things so that override.ini could have all the same
> values as application.ini. I certainly had a patch queue to do that at some
> point in the past! ;-)
> 
> It's silly for a file named override.ini to contain just this single option.

That would be brilliant and would solve so many other usecases.

You would have a lot of very happy people.
Duplicate of this bug: 924056

This isn't really relevant anymore (plus we have policy).

We should probably consider removing override.ini support at some point...

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.