Disabled input text field not changing background color

RESOLVED DUPLICATE of bug 451771

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 451771
5 years ago
3 years ago

People

(Reporter: Wayne, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130511120803

Steps to reproduce:

Using Windows 7 SP1 and Firefox 21.0, I viewed the following HTML file

<input type="text" value="hello">
<input type="text" value="hello" disabled="">


Actual results:

The background-color of the disabled input field was the same as the first field.  It was white instead of dimmed/gray




Expected results:

The background-color of the text input element should have been rendered as "threedface" or #F0F0F0.  The same HTML rendered correctly using Firefox 21.0 on a Windows XP system.  Also the background colors between the enabled and disabled fields were different when using Chrome Version 26.0.1410.64 m and IE 10.0.4.

Updated

5 years ago

Comment 1

5 years ago
WFM with FF21 on Win 7: http://i.imgur.com/8EbXdtv.png

Could you try with a fresh profile, please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(wayne.westmoreland)
(Reporter)

Comment 2

5 years ago
Your screen shot (http://i.imgur.com/8EbXdtv.png) shows exactly the problem I am having.  See how the background color is the same between the two fields?  If you examine the styles for those two fields you see that the background-color for the enabled field is supposed to be #FFFFFF and that field is rendered correctly with that background color. However the disabled field's background-color is supposed to be #F0F0F0 but instead it is also rendered as #FFFFFF.

BTW, I tried using a fresh profile, the behavior was the same.

Unless I'm mistaken the background-color for the disabled field is being set (but incorrectly rendered by FF) in the following style entry in forms.css:

input:disabled, textarea:disabled, option:disabled, optgroup:disabled, select:disabled:disabled {
    -moz-user-focus: ignore;
    -moz-user-input: disabled;
    background-color: threedface;
    color: graytext;
    cursor: inherit;
}
Flags: needinfo?(wayne.westmoreland)

Comment 3

5 years ago
Works for me with firefox-20.0b7.es-ES.linux64 and 22.0 Beta.

Comment 4

5 years ago
(In reply to Aleksej [:Aleksej] from comment #3)
> Works for me with firefox-20.0b7.es-ES.linux64 and 22.0 Beta.

Could you attach a screenshot of what you're seeing please.
Flags: needinfo?(deletesoftware+moz)

Comment 5

5 years ago
Created attachment 752073 [details]
screenshot: WFM on GNU/Linux (Fx 22.0 Beta, data URI added before comment 0)
Flags: needinfo?(deletesoftware+moz)

Comment 6

5 years ago
Created attachment 752078 [details]
Reporter's testcase with CSS style

Ok, with the CSS style given in comment #2, it works. But not with the simple code given in comment #0.

Updated

5 years ago
Attachment #752073 - Attachment description: screenshot: WFM on GNU/Linux (Fx 22.0 Beta) → screenshot: WFM on GNU/Linux (Fx 22.0 Beta, data URI added before comment 0)

Comment 8

5 years ago
(In reply to Aleksej [:Aleksej] from comment #7)
WFM, but the color is different.

Comment 9

5 years ago
On my side (Win 7), the data URI doesn't work, the background of the 2nd input stay white.

Comment 10

5 years ago
WFM on the latest Nightly and Firefox 21 builds, with the reporter's testcase. The background for the first input field is white, while for the second one it's light gray. The text in the first input field is black, while in the second one is gray.

Do you have any addons installed that might affect how websites are displayed? Please try reproducing this issue with a clean profile:
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(wayne.westmoreland)

Comment 11

5 years ago
(In reply to Ioana Budnar, QA [:ioana] from comment #10)
> WFM on the latest Nightly and Firefox 21 builds, with the reporter's
> testcase. The background for the first input field is white, while for the
> second one it's light gray. The text in the first input field is black,
> while in the second one is gray.
> 
> Do you have any addons installed that might affect how websites are
> displayed? Please try reproducing this issue with a clean profile:
> http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

Sorry, I missed this important part: I tested this on Windows 7 64-bit and on Ubuntu 13.04 32-bit.
(Reporter)

Comment 12

5 years ago
The first thing Loic had me do was re-test with a clean profile, I just tried it again, I created a new profile, disabled all extensions and plugins.  The disabled field's background color still rendered as white. (I'm also using Windows 7 64-bit).
Flags: needinfo?(wayne.westmoreland)

Updated

5 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

Updated

3 years ago
Duplicate of this bug: 1066860

Comment 14

3 years ago
Jim, you marked this invalid in bug 451771 - but it seems IE and Chrome act differently here. Is that reason enough to reconsider?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jmathies)
Hardware: x86_64 → All
Version: 21 Branch → Trunk

Comment 15

3 years ago
(In reply to :Gijs Kruitbosch from comment #14)
> Jim, you marked this invalid in bug 451771 - but it seems IE and Chrome act
> differently here. Is that reason enough to reconsider?

dupe this over to bug 451771 I guess? Also, that would make a [good first bug][lang=c++], with you as the mentor! :)
Flags: needinfo?(jmathies)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451771
You need to log in before you can comment on or make changes to this bug.