[Calendar] Calendar chooser in add event is missing calendars with multi calendars added

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: tchung, Assigned: jlal)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g18-v1.0.1 affected, b2g-v1.1hd fixed)

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 749475 [details]
multi-calendar view

Add multiple caldav calendars (ie. Google and Yahoo) When adding a new event, notice the calendar event chooser is missing all the calendar categories

See screenshots

REpro:
1) install inari 1.0.1 nightly build
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/08196b630a4a
Gaia   57188a05fe5b669fc98bfcc18a49c9b3effdac06
BuildID 20130514070202
Version 18.0
2) launch Calendar, and add 2 caldav calendars (Google & Yahoo)
3) view the calendar list, and check if all your calendars are properly checked and active
4) go to calendar mode, and add an Event
5) below the month dropdown, click on the calendar type
6) Verify calendar chooser is missing categories to add event to.

Expected;
- add event options should show all active calendar choices

Actual:
- missing calendar events in chooser dropdown.
(Reporter)

Comment 1

6 years ago
Created attachment 749476 [details]
add event - no categories 1
(Reporter)

Comment 2

6 years ago
Created attachment 749478 [details]
add event - no categories 2
(Assignee)

Comment 3

6 years ago
Any adb information here?
I was seeing this also during our bug bash - we're missing calendars in the listing in a bunch of cases. Probably a recent regression.
blocking-b2g: --- → tef?
Keywords: regression
status-b2g18-v1.0.1: --- → affected
(Assignee)

Updated

6 years ago
Blocks: 855334
(Reporter)

Comment 5

6 years ago
(In reply to James Lal [:lightsofapollo] from comment #3)
> Any adb information here?

none unfortunately.
(Assignee)

Comment 6

6 years ago
Hmm- what happens when you restart calendar? if this is a permanent issue then its definitely related to the set of calendars synced.
(In reply to James Lal [:lightsofapollo] from comment #6)
> Hmm- what happens when you restart calendar? if this is a permanent issue
> then its definitely related to the set of calendars synced.

When I saw this on my end, this wasn't permanent. It was an issue during the existing running of the calendar app.
tef- given these STR work.

1) set up calendar
2) add event without category

1) set up calendar
2) quit app or restart phone at any time
3) add event with category
blocking-b2g: tef? → -
(Assignee)

Comment 9

6 years ago
Just noticed something here: By category do you mean calendar?
Flags: needinfo?(jsmith)
(Assignee)

Comment 10

6 years ago
Tony- can we sit down Thursday and try this out with your credentials? I will keep trying to reproduce but so far its working for me.
Flags: needinfo?(tchung)
(Reporter)

Comment 11

6 years ago
(In reply to James Lal [:lightsofapollo] from comment #9)
> Just noticed something here: By category do you mean calendar?

yeah i meant calendars.  my google calendar has different calendars-- and they are all missing from the dropdown list.
Flags: needinfo?(tchung)
I'm guessing you meant to send that question to Alex. I don't understand what that means either in comment 8.
Flags: needinfo?(jsmith) → needinfo?(akeybl)
(Assignee)

Updated

6 years ago
Summary: [Calendar] Calendar chooser in add event is missing categories with multi calendars added → [Calendar] Calendar chooser in add event is missing calendars with multi calendars added
Renoming for reanalysis since comment 8 makes no sense.
blocking-b2g: - → tef?
Actually I'm hold off and do some more analysis.
blocking-b2g: tef? → ---
Keywords: qawanted
QA Contact: jsmith
Okay, confirmed we're referring calendars here. I got another reproduction of the bug, although the reproduction steps appear to be inconsistent on how to generate this bug.

I hit this situation after I had two calendars added, deleted the yahoo calendar, and tried to add an event. The result was the calendar list was entirely wrong - it was missing calendars from the google calendar list and still had the old yahoo calendars around.

I'll keep digging for consistent STR.
Flags: needinfo?(akeybl)
Going to double check this, but I think this is the STR here:

1. Import a google and yahoo calendar with some events
2. Revoke access to your google token
3. Sync - get the sync error
4. Delete the google calendar that had the sync error
5. Try to add an event and select the calendar listing

Result - The list is incorrect - it's missing yahoo calendars and has a couple of left over google calendars.

Now that I understand the STR here, this is definitely an edge case. This will only happen if a user decides to delete a google calendar that had a sync error and tries to add a new event without restarting the calendar.
Keywords: qawanted
status-b2g18: --- → affected
Confirmed comment 16 is consistent STR. However, you'll need to flash a clean build before attempting that STR - I had trouble reproducing it with a non-clean build.
05-16 12:41:57.874: E/GeckoConsole(438): Content JS LOG at app://calendar.gaiamobile.org/gaia_build_defer_index.js:661 in anonymous: [ caldav worker ] Could not sync:  /caldav/v2/pl19v8ck9sdghahjtdk4spm57g%40group.calendar.google.com/events/ ( handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js:777 )
05-16 12:41:58.054: E/GeckoConsole(438): Content JS LOG at app://calendar.gaiamobile.org/gaia_build_defer_index.js:661 in anonymous: [ caldav worker ] Could not sync:  /caldav/v2/t6efa1v22cnv6gm57757epuve8%40group.calendar.google.com/events/ ( handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js:777 )
(Assignee)

Updated

6 years ago
Duplicate of this bug: 880485
(Assignee)

Comment 21

6 years ago
Created attachment 759464 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10255

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #759464 - Flags: review?(gaye)
(Assignee)

Updated

6 years ago
Attachment #759464 - Flags: review?(gaye) → review?(kgrandon)
Attachment #759464 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/cfcea9998ac4b50ac221d59eb1709371f1ed6767
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Similar comment to another bug - this is worthwhile to uplift, but we just missed the date for uplifts. I think I'm going to followup with Alex on the uplift process here.
Duplicate of this bug: 900861

Updated

5 years ago
blocking-b2g: --- → leo+
Uplifted cfcea9998ac4b50ac221d59eb1709371f1ed6767 to:
v1-train: 69b5463afa93f9d82f68ce3cb3a51b9fbc1513aa
status-b2g18: affected → fixed
Assignee: nobody → jlal
v1.1.0hd: 69b5463afa93f9d82f68ce3cb3a51b9fbc1513aa
status-b2g-v1.1hd: --- → fixed

Comment 27

5 years ago
Verifying as fixed,this issue no longer Reproduces on v1.1 Leo Commercial. 
calendar chooser is not missing categories to add event to.

Environmental Variables
Build ID: 20130815041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/692d3414bb12
Gaia: 0f1f1ab0ab31a1df8a780baa048b5e7b2854205d
Platform Version: 18.1
RIL Version: 01.01.00.019.190
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.