Reset PIN redirects to confirm PIN

RESOLVED FIXED in 2013-05-16

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: kumar)

Tracking

({regression})

2013-05-16
x86
Mac OS X
regression
Points:
---

Details

STR
- log in to Marketplace with a new email
- search for Private Yacht and tap purchase
- create a PIN
- confirm the PIN
- close the payment flow
- tap purchase on Private Yacht again to restart the flow
- tap Forgot PIN

Expected: You should see "are you sure you want to reset your PIN?"
Actual: You are redirected to a confirm PIN screen

Bonus points: this only happens on the first try! If you close the payment flow and tap Foregot PIN then it works as expected. 

I thought this was fallout from bug 850084 but it might have been happening all along
https://github.com/mozilla/webpay/pull/124/files
Assignee: nobody → kumar.mcmillan
Priority: -- → P2
Target Milestone: --- → 2013-05-16
https://github.com/mozilla/webpay/commit/00405efaa5e9630a2d3fd34c6bbad415306712fd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Keywords: regression

Comment 3

5 years ago
I followed the STRs and now when pressing "Forgot Pin " at last step, a blank page with waiting spinning wheel is continuously displayed and Pin cannot be changed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Victor Carciu from comment #3)
> I followed the STRs and now when pressing "Forgot Pin " at last step, a
> blank page with waiting spinning wheel is continuously displayed and Pin
> cannot be changed.

See bug 886742 - the permanent "loading message" seems to be caused by a 500 at bango's end and how we are handling it. Once this is fixed you should be able to re-verify.
Added bug 886760 as a dep which is the bango side of bug 886742.

Comment 6

5 years ago
Thanks Stuart. I will mark it as fixed again and I will verify when possible.

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.