Closed Bug 872307 Opened 7 years ago Closed 7 years ago

3d-assembly does not draw anything

Categories

(Core :: Canvas: WebGL, defect)

24 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24
Tracking Status
firefox24 --- verified

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/81dd97739fa1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130514 Firefox/24.0 ID:20130514031031

Steps To Reproduce:
1. Start Nightly with clean profile
2. Open https://developer.mozilla.org/ja/demos/tag/tech:webgl
3. Laounch "3D ASSEMBLY" or Open direct link URL

Actual Results:
3d-assembly does not draw anything

Regression window(m-i):
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5a3487239596
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130513 Firefox/23.0 ID:20130513044518
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a16f28a76fcc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130513 Firefox/23.0 ID:20130513051919
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5a3487239596&tochange=a16f28a76fcc

Triggered by: Bug 861039

Graphics
Adapter Description	ATI Radeon HD 4300/4500 Series
Adapter Drivers	aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	512
ClearType Parameters	Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50
Device ID	0x954f
Direct2D Enabled	true
DirectWrite Enabled	true (6.1.7601.17789)
Driver Date	11-16-2012
Driver Version	8.970.100.7000
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
Warning in Error Console:
Timestamp: 2013/05/15 9:08:21
Warning: Error: WebGL: linkProgram: a fragment shader used in this program failed to compile, with this log:
ERROR: 0:1: 'highp' : precision is not supported in fragment shader 


Source File: https://developer.cdn.mozilla.net/media/uploads/demos/R/a/RayChen/69dfb39a1a35bb6aabc76c4e9ff207c9/3d-assembly_1363157228_demo_package/js/three.min.js
Line: 692

Timestamp: 2013/05/15 9:08:21
Warning: Error: WebGL: linkProgram: a fragment shader used in this program failed to compile, with this log:
ERROR: 0:1: 'highp' : precision is not supported in fragment shader 


Source File: https://developer.cdn.mozilla.net/media/uploads/demos/R/a/RayChen/69dfb39a1a35bb6aabc76c4e9ff207c9/3d-assembly_1363157228_demo_package/js/three.min.js
Line: 672

Timestamp: 2013/05/15 9:08:22
Warning: Error: WebGL: attachShader: shader: null object passed as argument
Source File: https://developer.cdn.mozilla.net/media/uploads/demos/R/a/RayChen/69dfb39a1a35bb6aabc76c4e9ff207c9/3d-assembly_1363157228_demo_package/js/three.min.js
Line: 489

Timestamp: 2013/05/15 9:08:22
Warning: Error: WebGL: linkProgram: this program doesn't have both a vertex shader and a fragment shader
Source File: https://developer.cdn.mozilla.net/media/uploads/demos/R/a/RayChen/69dfb39a1a35bb6aabc76c4e9ff207c9/3d-assembly_1363157228_demo_package/js/three.min.js
Line: 489

Timestamp: 2013/05/15 9:08:22
Warning: Error: WebGL: useProgram: program was not linked successfully
Source File: https://developer.cdn.mozilla.net/media/uploads/demos/R/a/RayChen/69dfb39a1a35bb6aabc76c4e9ff207c9/3d-assembly_1363157228_demo_package/js/three.min.js
Line: 358
Depends on: 872701
Works for me too
http://hg.mozilla.org/mozilla-central/rev/ea767da526ff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130517 Firefox/24.0 ID:20130517031000
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
WFM on Windows with the latest Nightly now available.
Resolution: WORKSFORME → FIXED
Target Milestone: --- → mozilla24
Verified fixed on Fx 24 beta 9, buildID 20130905180733.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.