Web Console is not cleared on page load

RESOLVED DUPLICATE of bug 705921

Status

()

Firefox
Developer Tools: Console
--
trivial
RESOLVED DUPLICATE of bug 705921
5 years ago
5 years ago

People

(Reporter: louisstow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Existing console logs are not very useful after a new page load/refresh.
(Reporter)

Comment 1

5 years ago
Created attachment 749646 [details] [diff] [review]
Patch to clear console on page load
Attachment #749646 - Flags: review?(mihai.sucan)
(Reporter)

Updated

5 years ago
Attachment #749646 - Attachment is patch: true
Attachment #749646 - Attachment mime type: text/x-patch → text/plain
Comment on attachment 749646 [details] [diff] [review]
Patch to clear console on page load

Review of attachment 749646 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you for bug report and for the patch! Unfortunately, this is not the right approach for fixing this bug.

The web console is split between a client and a server. Please see the details about Web Console remoting. [1] You need to listen to the tabNavigated event from the remote server.

You also need to add a preference to allow users to persist web console output - some do not want to always clear output on page navigation/reload.

Lastly, you also need to write a test.

[1] https://developer.mozilla.org/en-US/docs/Tools/Web_Console/remoting
Attachment #749646 - Flags: review?(mihai.sucan)
This bug is also a duplicate...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705921
Louis: please submit the updated patch in bug 705921. Thank you!
You need to log in before you can comment on or make changes to this bug.