Activation does not open the sidebar if previously closed

RESOLVED WONTFIX

Status

()

Firefox
SocialAPI
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: edA-qa mort-ora-y, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
If a social provider has a sidebar it should be opened when they activate that provider. Currently if they sidebar was previously active, then closed, and then a provider is activated, the sidebar stays closed.

0. With a clean profile
1. Goto https://mozsocial.cliqz.com/
2. Click "Activate"
3. Sidebar is shown
4. From menu hide the sidebar
5. From menu select "Remove Cliqz"
6. Goto https://mozsocial.cliqz.com/
7. Click "Activate"
8. Provider is reenabled, but...
8a. sidebar is not opened (error)

Also, not quite as complex, but I think "Activate" should just always open the sidebar. As a reducated flow simply hide the sidebar then press "Activate" again, it won't show either.
Basically what is happening here is that reinstalling a provider restores it's previous state. I'm not sure if this was intended or not so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 21 Branch → Trunk
Not really intended, IMO also not a big deal for 21.  Lets look at this for 22/23.
(Reporter)

Comment 3

5 years ago
Thinking from a user viewpoint I'd wonder why my settings are retained when I remove the service.

Though it's definitely not a vital issue at the moment, 22/23 would be fine.
(In reply to edA-qa mort-ora-y from comment #3)
> Thinking from a user viewpoint I'd wonder why my settings are retained when
> I remove the service.

I think *you* as a user might think that way but I think it's just as likely that some users might think why are my settings not retained.

> Though it's definitely not a vital issue at the moment, 22/23 would be fine.

Agreed.
IMO, activate should always open the sidebar.  I just struck it with a new provider (ie, not when re-installing an old one) and it seems strange to me that even though I'd closed it previously for a different provider, the sidebar wasn't opened for this new provider.  And FWIW, I think it's also fine to just re-open it when re-activating an existing one.
(In reply to Mark Hammond (:markh) from comment #5)
> IMO, activate should always open the sidebar.

I concur!
deprecation in fx51
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.