Closed Bug 872439 Opened 7 years ago Closed 7 years ago

Changes in packager breaks Firefox + libxul build

Categories

(Firefox Build System :: General, defect)

21 Branch
x86_64
Linux
defect
Not set

Tracking

(firefox21+ affected, firefox22 fixed, firefox23 fixed, firefox24 fixed)

RESOLVED FIXED
mozilla24
Tracking Status
firefox21 + affected
firefox22 --- fixed
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: jhorak, Assigned: glandium)

References

Details

(Keywords: regression)

Attachments

(1 file)

We've got problem with change introduced by bug 780561 when building Firefox 
with libxul on Fedora.
I get:
Executing /usr/lib64/xulrunner-devel-21.0/bin/xpcshell -g /usr/lib64/xulrunner-devel-21.0 -a /home/jhorak/fedora/firefox/firefox-21.0/mozilla-release/dist/bin/browser -f ../../toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://app/");
failed to get nsJSRuntimeService!
Traceback (most recent call last):
  File "../../toolkit/mozapps/installer/packager.py", line 366, in <module>
    main()
  File "../../toolkit/mozapps/installer/packager.py", line 358, in main
    args.source, gre_path, base)
  File "../../toolkit/mozapps/installer/packager.py", line 140, in precompile_cache
    errors.fatal('Error while running startup cache precompilation')
  File "/home/jhorak/fedora/firefox/firefox-21.0/mozilla-release/python/mozbuild/mozpack/errors.py", line 101, in fatal
    self._handle(self.FATAL, msg)
  File "/home/jhorak/fedora/firefox/firefox-21.0/mozilla-release/python/mozbuild/mozpack/errors.py", line 96, in _handle
    raise ErrorMessage(msg)
mozpack.errors.ErrorMessage: Error: Error while running startup cache precompilation
make[1]: *** [stage-package] Error 1

It looks fine when -g /usr/lib64/xulrunner-devel-21.0 is replaced by -g /usr/lib64/xulrunner-devel-21.0/bin
Version: 17 Branch → 21 Branch
Jan, can you check this?

A workaround that should work, if you don't want to apply a patch, is to run:
make package LIBXUL_DIST=/usr/lib64/xulrunner-devel-21.0/bin.
Attachment #749765 - Flags: review?(gps)
Assignee: nobody → mh+mozilla
Please check that the patch fixes it for you whether you want to apply it in the packaging or not, though.
Blocks: new-packager
Problem has been fixed with attached patch.
Keywords: regression
Attachment #749765 - Flags: review?(gps) → review+
Comment on attachment 749765 [details] [diff] [review]
Fix GRE path used for startup cache precompilation with --with-libxul-sdk

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 780561
User impact if declined: make package failure on builds with --with-libxul-sdk (xulrunner applications)
Testing completed (on m-c, etc.): tested locally by Jan
Risk to taking this patch (and alternatives if risky): NPOTB for Firefox
String or IDL/UUID changes made by this patch: None

(requesting for release in case there's a chemspill planned)
Attachment #749765 - Flags: approval-mozilla-release?
Attachment #749765 - Flags: approval-mozilla-beta?
Attachment #749765 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/15ba59a74221
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Attachment #749765 - Flags: approval-mozilla-beta?
Attachment #749765 - Flags: approval-mozilla-beta+
Attachment #749765 - Flags: approval-mozilla-aurora?
Attachment #749765 - Flags: approval-mozilla-aurora+
Does this affect FF21?  We could consider it for a ride-along if there was a 21.0.1 at some point in the coming weeks if so.  Otherwise it will be fixed in FF22.
Flags: needinfo?(jhorak)
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> Does this affect FF21?  We could consider it for a ride-along if there was a
> 21.0.1 at some point in the coming weeks if so.  Otherwise it will be fixed
> in FF22.

Yes it does. We've fixed that in our package by using attached patch.
Flags: needinfo?(jhorak)
There is no planned chemspill at this point for Fx21.0, so I am removing the approval for release on this patch .

I will revisit the issue if at all there is a chemspill/dot release in future weeks but seems unlikely at this point.
Attachment #749765 - Flags: approval-mozilla-release? → approval-mozilla-release-
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.