Add-ons section can go missing in about:home

VERIFIED FIXED in Firefox 23

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: u421692, Assigned: bnicholson)

Tracking

({regression, reproducible})

23 Branch
Firefox 24
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox23 verified, firefox24 verified, fennec23+)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 749889 [details]
Screenshot

Environment:
Build: Firefox for Android 24.0a1 (2013-05-15)
Device: Acer Iconia Tab A500
OS: Android 3.2.1

Steps to reproduce:
1. Start Firefox(about:home page is displayed)
2. Change device orientation for a couple of times(you may have to repeat this step for a significant number of times)

Expected result:
about:home page is repainted without any issues.

Actual result:
Add-ons section disappear from page(see attached screenshot)

Note: This issue is also reproducible on Samsung Galaxy S2 and Samsung Galaxy Tab 10.1(GT-P7510)
The only workaround I found is to start firefox with a new profile.
(Reporter)

Comment 1

5 years ago
Created attachment 749891 [details]
logcat
(In reply to Pop Mihai from comment #0)
> 2. Change device orientation for a couple of times(you may have to repeat
> this step for a significant number of times)

Lovely.
Created attachment 749911 [details]
Nightly (05/15) - Screenshot

I am able to reproduce this on my Nexus 4 (Android 4.2.2); not sure entirely what triggered it but some combination of closing about:home and rotating to landscape did it.

Updated

5 years ago
tracking-fennec: --- → ?
status-firefox23: --- → affected
status-firefox24: --- → affected
Keywords: reproducible
OS: Linux → Android
Hardware: x86_64 → ARM
Assignee: nobody → bnicholson
tracking-fennec: ? → 23+
Created attachment 750590 [details]
Nightly (05/16) - Screenshot

I'm seeing this after my synced tabs appear; it knocks off the add-ons area.
Attachment #749911 - Attachment is obsolete: true

Updated

5 years ago
Summary: Add-ons section is missing in about:home page after changing device orientation → Add-ons section can go missing in about:home

Updated

5 years ago
Version: Firefox 24 → Firefox 23

Updated

5 years ago
Keywords: regression, regressionwindow-wanted
(Assignee)

Updated

5 years ago
Blocks: 798358
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

5 years ago
The regression window for this issue is:
1. mozilla central
good build: fennec-23.0a1 (13.05.2013)
bad build: fennec-24.0a1 (14.05.2013) 

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7130e5134a6e&tochange=81dd97739fa1

2. inbound
good build: 1368461162
bad build:  1368470591

pushlog:
hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4f44cdf5aafc&tochange=9595c81d7591
Looks like bug 871022 regressed this.
Blocks: 871022
No longer blocks: 798358
I thought Brian said it was a missing "learnmoreURL" item in the recommended-addons.json file.
(Assignee)

Comment 8

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #7)
> I thought Brian said it was a missing "learnmoreURL" item in the
> recommended-addons.json file.

It is. Bug 798358 doesn't show up in the window from comment 5, but I can confirm that adding a safety check for learnmoreURL fixes the issue.
Blocks: 798358
No longer blocks: 871022
(Assignee)

Comment 9

5 years ago
Created attachment 751757 [details] [diff] [review]
Add check for missing learnmoreURL in recommended-addons.json
Attachment #751757 - Flags: review?(mark.finkle)
Attachment #751757 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/b0d07be09b86
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
(Assignee)

Comment 12

5 years ago
Comment on attachment 751757 [details] [diff] [review]
Add check for missing learnmoreURL in recommended-addons.json

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 798358
User impact if declined: addons section missing from about:home
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch:none
Attachment #751757 - Flags: approval-mozilla-aurora?
Attachment #751757 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 24.0a1 (2013-05-23)
Device: Acer Iconia Tab A500
OS: Android 3.2.1
status-firefox24: fixed → verified
(Reporter)

Comment 15

5 years ago
Verified fixed on:
Build: Firefox for Android 23.0b6
Device: LG Nexus 4
OS: Android 4.2.2
status-firefox23: fixed → verified

Comment 16

4 years ago
As per commnet #13 and comment #15
> Build: Firefox for Android 24.0a1 (2013-05-23)
> Build: Firefox for Android 23.0b6

setting the bug to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.