Closed Bug 872620 Opened 7 years ago Closed 6 years ago

Moving a gripper past the other gripper should not cause the second gripper to move

Categories

(Firefox for Metro Graveyard :: Input, defect, P3)

All
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 858206

People

(Reporter: TimAbraldes, Unassigned)

Details

STR:
  1) Put text selection grippers on a small word ("an," "the," etc)
  2) Place your finger over both selection grippers simultaneously
  3) Move your finger and watch the grippers follow you around the page
To be prioritized.
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=0
Priority: -- → P3
Updating the title; I think it's fine if a user wants to move both selection grippers at the same time, as long as the user is doing so with two distinct fingers.
Summary: Defect - It should not be possible to move both selection grippers simultaneously → Defect - It should not be possible to move both selection grippers with a single finger
Is this one ready to go? Does it need anything? If not, please mark it [shovel-ready]
(In reply to :Ally Naaktgeboren from comment #3)
> Is this one ready to go? Does it need anything? If not, please mark it
> [shovel-ready]

It's p3 so shouldn't be a priority over other work.
I realized what's actually going on here: Moving a gripper past the other gripper currently causes the other gripper to move.

In my mind, the gripper that is being moved should not "bump" the other gripper. I think it would be a better experience if the other gripper remains anchored, and the text selection is just whatever text happens to be between the two grippers. This is more familiar since it better mimics what happens when text is being selected with the mouse.
Blocks: 831985
No longer blocks: caret-sel
Summary: Defect - It should not be possible to move both selection grippers with a single finger → Defect - Moving a gripper past the other gripper should not cause the second gripper to move
Отличный сайт! С ( http://lazurit-bazalt.ru/ ) огромным уважением, Ваш ( http://yunona-gorizont.ru/ ) преданный читатель ( http://akvamarin-palladium.ru/ ) Илья Денисович ( http://delta-arsenal.ru/ ) Середич из города ( http://hrizolit-afina.ru/ ) Канино. Завтра ( http://astra-kassipoeya.ru/ ) снова зайду. До новых встречь!
No longer blocks: metrov2defect&change
Summary: Defect - Moving a gripper past the other gripper should not cause the second gripper to move → Moving a gripper past the other gripper should not cause the second gripper to move
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=0 → [defect] p=0
Whiteboard: [defect] p=0 → [selection] [defect] p=0
Blocks: 957244
No longer blocks: 831985
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858206
No longer blocks: metrobacklog, 957244
Whiteboard: [selection] [defect] p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.