Closed Bug 872803 Opened 8 years ago Closed 8 years ago

TScroll uses setInterval instead of requestAnimationFrame

Categories

(Testing :: Talos, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 845943

People

(Reporter: mattwoodrow, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

This isn't tied to our painting rate, so we end up dropping frames.

Switching to requestAnimationFrame should guarantee that every frame of the scroll gets painted, and would more accurately measure how fast we can repaint scroll changes.

This will cause a regression in the numbers reported though, since we'll be painting more frames.
Attachment #750129 - Flags: review?(roc)
Comment on attachment 750129 [details] [diff] [review]
Use requestAnimationFrame instead

Review of attachment 750129 [details] [diff] [review]:
-----------------------------------------------------------------

Notify dev.tree-management and dev.platform when this lands.
Attachment #750129 - Flags: review?(roc) → review+
Attached patch Update talos.json (obsolete) — Splinter Review
Attachment #750164 - Flags: review?(jmaher)
This is a duplicate of bug 845943, which fixes it for all scroll sub-tests (not just the tiled* ones).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 845943
Attachment #750164 - Attachment is obsolete: true
Attachment #750164 - Flags: review?(jmaher)
You need to log in before you can comment on or make changes to this bug.