Unknown username causing traceback in account portal

VERIFIED WONTFIX

Status

Cloud Services
Server: Account Portal
VERIFIED WONTFIX
5 years ago
4 years ago

People

(Reporter: bobm, Assigned: rfkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa?])

(Reporter)

Description

5 years ago
Unknown users cause account portal to throw a traceback, as in the following instance:
2013-05-15 12:58:20,835 ERROR [accountportal] Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/services/util.py", line 304, in __call__
    return self.app(environ, start_response)
  File "/usr/lib/python2.6/site-packages/beaker/middleware.py", line 152, in __call__
    return self.wrap_app(environ, session_start_response)
  File "/usr/lib/python2.6/site-packages/webob/dec.py", line 147, in __call__
    resp = self.call_func(req, *args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/webob/dec.py", line 208, in call_func
    return self.func(req, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/accountportal/wsgiapp.py", line 180, in __call__
    result, text = self.controllers['console'].log_in(request)
  File "/usr/lib/python2.6/site-packages/accountportal/controllers/console.py", line 76, in log_in
    extract_username(request.POST.get('username'))
  File "/usr/lib/python2.6/site-packages/services/user/__init__.py", line 62, in extract_username
    raise ValueError("Invalid username: %r" % (username,))
ValueError: Invalid username: u''
(Assignee)

Updated

5 years ago
Assignee: nobody → rfkelly

Updated

5 years ago
Component: Firefox Sync: Backend → Server: Account Portal
QA Contact: jbonacci
Whiteboard: [qa?]
(Assignee)

Comment 1

4 years ago
Bob, what version of accountportal is currently deployed into production?  I fear that the dev version has moved a long way from what's currently deployed.  It may be better for us to revert dev to an old version and/or work off a branch for fixes like this.
Flags: needinfo?(bobm)
Pretty sure that 2.9.3 is the last version we have that's had serious testing done to it. Later versions work, but the build is a little screwed, and it's not been a priority to get it back. Branching from 2.9.3 makes the most sense.
(Reporter)

Comment 3

4 years ago
Dev is a bit behind the times: python26-accountportal-2.0-4.   Production: python26-accountportal-2.9-4
Flags: needinfo?(bobm)
Ah yes. 2.9.4 is already a branch with some build tweaks. We should be able to just continue from that point.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 957511
I think we're just going to live with this for the rest of AP lifetime.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
OK.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.