Buffered animated GIFs - Bug or intention, but not feature!

VERIFIED DUPLICATE of bug 17126

Status

()

Core
ImageLib
--
major
VERIFIED DUPLICATE of bug 17126
17 years ago
17 years ago

People

(Reporter: Lev, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
There is a well-known bug in Netscape Communicator AND Mozilla. I've already 
reported them 2 years before, but nothing happened ;-) Just look in the .js 
files used by the html files listed above. I've written a simple function to 
preload GIF-files, which works fine with IE 4.X and Netscape Communicator 4.3 
and higher.
The sites changes the buttons on the event "OnMouseOver" with an animated GIF 
and replaces it on "OnMouseOut" with another animated one (both being buffered).
While all browser preload the images fine, the display looks different and 
Mozilla really sucks up at this step:

---

Details of the tests (the GIFs are NOT looped up, only single sequence)

IE 4.X > : buffers correctly, animates correctly the GIF (only once)on 
OnMouseOver and animates correctly the 2th one on OnMouseOut (once too!)

Netscape Communicator 4.3x > : buffers correctly, animates correctly the first 
GIF but displays on OnMouseOut only the last sequence of the second GIF-file. 
Not serious, but it nerves!

Mozilla 6.1 SR 1 : buffers correctly, but displays all GIFs in a loop! 

I'll try to make the testing with Opera too next time.

---

There are style-sheets an layout positioning errors on www.adwww.de made by 
Mozilla too, but I'll report them in a separate bug-report.
If you guys want to go with that nice beast on serious competition with 
Micro$oft, you should remove such primitive bugs first.
I'm not a die-hard bug reporter, my really occupation is dynamic web-building. 
But these bugs are very old and should be solved, they really annoy us in our 
businness trend ;-)

Thanx for making Mozilla better, hope it will become something incomparable!

Lev

Comment 1

17 years ago
Yes, we've known about this for a long time.  Why not go vote for it on the
other bug, since this is a DUP.

*** This bug has been marked as a duplicate of 17126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Formally reopening and reassigning to ImageLib component; will dupe again
below. This is not JavaScript Engine, and I don't know enough about this
to verify the dupe -
Status: RESOLVED → UNCONFIRMED
Component: Javascript Engine → ImageLib
Resolution: DUPLICATE → ---

Comment 3

17 years ago
Based on Aaron's comment above, duping against bug 17126.
If anyone disagrees, please reopen the bug; thanks - 

*** This bug has been marked as a duplicate of 17126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Argh!!! Owner and QA need to be changed; reopening again; sorry!!!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
Reassigning to ImageLib component, owner, and QA -
Assignee: rogerl → pavlov
QA Contact: pschwartau → tpreston

Comment 6

17 years ago
And duping again -

*** This bug has been marked as a duplicate of 17126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verirfied Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.