Mailto Protocol gets deleted after each reboot.

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jebus.2504, Unassigned)

Tracking

21 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130511120803

Steps to reproduce:

I set my mailto preference to Gmail.


Actual results:

After a reboot there is no mailto option visible in the applications list in FF preferences. Instead when I click on a mailto link, FF opens Thunderbird.


Expected results:

The mailto application preference choice should have survived a reboot. There should still be an option to select the default mailto application handler after a reboot. I tried the workaround suggested here:

http://kb.mozillazine.org/Changing_the_mail_program_used_in_Firefox

Including quitting FF and  deleting mimetypes.rdf before relaunching. However while this brings back the mailto option in FF application preferences, after a reboot this option is again deleted from the application preferences list.

Comment 1

5 years ago
Could you make a test with a new profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → File Handling
Flags: needinfo?(jebus.2504)
Also, if you still reproduce the issue after following comment 1, could you please also try running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
(Reporter)

Comment 3

5 years ago
I appreciate you guys want me to test. But I have exams. Even if a new profile 'resolved' the problem, it would not offer a resolution for me, as I have retained my profile for over 3 years, through various iterations of FF and it contains too much of use to lose it all now.

This didn't start happening until 20.1. Everything was fine before then. I did an upgrade from Win 7 to Win 8, but nothing else has changed on my system whatsoever.

I will test fully during the holidays in 2 weeks and report back then.
Flags: needinfo?(jebus.2504)
(Reporter)

Comment 4

5 years ago
So OK sorry for the delay. I tested with a new profile and the problem isn't present. This isn't surprising, as it is what you would expect with a default clean install of FF.

I restarted with my own profile in safe mode, but in this scenario the problem persists.

However I wish to clarify and update this bug. FF forgets any and ALL default application program settings after a reboot, so for example if I open a torrent file, or a .pdf file or anything of this sort, I can tell it to use a specific application. This program association will persist until the next reboot, thereafter the process needs to be repeated again. HOWEVER, only the mailto option completely disappears (as far as I currently know) after each reboot. For all other application and file associations the "Applications' list in FF options is still populated. Only the mailto option is entirely missing. Deleting mimeTypes.rdf and restarting Firefox restores the mailto option, but again this only persists until the next reboot.

I do not wish to risk losing my profile if I can. I have nurtured my profile over some years and it is of significant value to me.

Comment 5

5 years ago
Read the FAQ, it explains how to to migrate your current profile and keep your essential data.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
I have done exactly this. This has not resolved this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

5 years ago
New profile works and nobody is able to repro it, so there's likely nothing to fix, especially with a 3-year-old profile (bad pref, bad add-on, etc).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

5 years ago
I'm not certain you have read this bug? I have successfully migrated my profile. This has nothing to do with how to migrate my profile. I have migrated my profile successfully for a number of years. However with all recent iterations of Firefox up to 22.0, every time I select an application from the default list of programs via tools -> options -> applications to handle a particular file type, then reboot, this application choice is not remembered in the next restart of Firefox. Moreover the mailto (and possibly several other Mimetype application handlers) is missing entirely from the tools -> options -> applications list. Closing FF and deleting mimetypes.rdf in the FF profile folder and then restarting FF causes the default application list to reset. If I do delete mimetypes.rdf the mailto option also returns. However after a reboot I have to repeat this entire process again.

Please read the bug fully before marking as resolved.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

5 years ago
Please stop marking this as resolved. I don't see why I should have to throw my entire profile away just to 'fix' this issue.
(Reporter)

Comment 10

5 years ago
How about we try something constructive? What do I need to do to set gmail at the default mailto file handler in about:config?
(In reply to jebus.2504 from comment #10)
> How about we try something constructive? What do I need to do to set gmail
> at the default mailto file handler in about:config?

Maybe this will help you: https://support.mozilla.org/ro/kb/change-program-used-open-email-links
Closing this, but please reopen the bug if you still see this issue. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.