No rightclick context menu on page with background image

VERIFIED FIXED in mozilla0.9.2

Status

SeaMonkey
UI Design
--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Tom Mraz, Assigned: dougt)

Tracking

({regression})

Trunk
mozilla0.9.2
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for 0.9.2, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The summary says it all.
Try rightclick on the specified page or any other with background image.
(Reporter)

Comment 1

17 years ago
I've forgot to add a build info:
Linux 2001062121
Severity: major → critical
Keywords: regression
(Reporter)

Comment 2

17 years ago
Also when you click on the Pictures link and you have enough free place under
the images you can right-click there and the menu now appears.
Strange.
Assignee: pinkerton → blake
Component: XP Toolkit/Widgets: Menus → XP Apps: GUI Features
QA Contact: jrgm → sairuh
content, not toolkit

Comment 4

17 years ago
Seeing this in win32 marking all
OS: Linux → All
ouch, i also see this when my theme for http://my.yahoo.com uses a background.
tested with 2001.06.22.06 comm bits on linux. will check mac soon...
Severity: critical → major
Keywords: nsBranch
able to repro using 2001.06.22.08 moz bits on Mac.
Keywords: mozilla0.9.3, nsdogfood
Hardware: PC → All

Comment 7

17 years ago
It happened last time as bug 80473.

Comment 8

17 years ago
jst backed the patch in that other bug out. -> jst
Assignee: blake → jst
Blake, please explain. I see context menus when I reightclick on background
images on http://www.roumen.cz/, what did I back out? This WORKSFORME, AFAICT.

Comment 10

17 years ago
See also bug 87524 -- it should be marked a dupe of this bug but has some more
information in it.

Comment 11

17 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&bra
nchtype=match&dir=&file=nsContextMenu.js&filetype=match&who=jst%25netscape.com&w
hotype=match&sortby=Date&hours=2&date=all&mindate=&maxdate=&cvsroot=%2Fcvsroot 
seems to undo the patch for bug 80473.  Am I missing the bigger 
picture/confused/drunk?

Comment 12

17 years ago
The patch for that bug was backed out, yes.  But on 06/21/2001 the URL parsing
branch landed which makes that previous approach obsolete, so it's of no
consequence.

See my comments in bug 87524 -- they point out that a regression was caused by
the checkin:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=nsContextMenu.js&filetype=match&who=dougt&whotype=regexp&sortby=Change+Size&hours=2&date=explicit&mindate=06%2F20%2F2001&maxdate=06%2F24%2F2001&cvsroot=%2Fcvsroot

Simple fix, just a misnamed variable.
Blake, you must be smoking crack, or something :-) I don't see anyhing wrong
with my checkin, I simply reverted the code to what it was before we supported
.baseURI on all nodes, that's all.

It looks like this is due to a mistake made by dougt in his URL parsing landing,
over to dougt.

        // Construct nsIURL.
        var ioService = Components.classes["@mozilla.org/network/io-service;1"]
                      .getService(Components.interfaces.nsIIOService);
        var uriToAdd  = ioService.newURI(base, null);
        // Resolve
        var result = baseURL.resolve( url );
        return result;
'baseURI' is not defined here any more, dougt, should baseURI be ioService here,
or something?
Assignee: jst → dougt
(Reporter)

Comment 14

17 years ago
*** Bug 87524 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
My webpage http://www.espectro.f2s.com) has a cyan-like background and i can see
the right click menu (html coded backgrounds of course do not make this bug appear)
But my older webpage http://espectro.hypermart.net/home.htm has a background
image, and right click menu is broken
I get the same problem shown in a dup:
Error: BaseURL is not defined
Source File: chrome://communicator/content/nsContextMenu.js Line : 682
Error: contextMenu has no properties
Source File: chrome://cookie/content/CookieContextOverlay.xul Line: 94

Btw, the Edit->Copy in the javascript console does not work! I had to type this
(Assignee)

Comment 16

17 years ago
Created attachment 39923 [details] [diff] [review]
Fixes problem.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: patch ready, need r=, sr=, a=
Target Milestone: --- → mozilla0.9.2

Comment 17

17 years ago
You apper to have approval for checkin after Mozilla freezes M0.9.2 (If not,
then this is it!)  To go in before then you'll need a= approval from Drivers. 
And, of course, r= and sr= in either case.

Comment 18

17 years ago
r/sr=alecf

Comment 19

17 years ago
I am smoking crack, yes.

Comment 20

17 years ago
r=gagan
Whiteboard: patch ready, need r=, sr=, a= → patch ready, need sr=, a=
(Assignee)

Updated

17 years ago
Whiteboard: patch ready, need sr=, a= → patch ready,a=

Comment 21

17 years ago
*** Bug 87741 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
a=chofmann branch and trunk
(Assignee)

Comment 23

17 years ago
thanks all.  fix checked into branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: patch ready,a= → critical for 0.9.2
vrfy fixed using this morning's branch comm bits on the three main platforms.
Keywords: vtrunk
*** Bug 88168 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
*** Bug 88843 has been marked as a duplicate of this bug. ***
almost forgot to vrfy this after i had filed bug 88407... context menus work on
the trunk when viewing a page w/backgrnd image. tested using:

* 2001.06.29.06 comm on win98
* 2001.06.28.04 comm on mac
* mozilla debug on linux from 6/28.
Status: RESOLVED → VERIFIED
Keywords: vtrunk
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.