[Email] Active Sync Mailbox continuously loading email when click on refresh on first auto retrieval.

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::E-Mail
P1
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Assigned: squib)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

(Whiteboard: [TD-28595], c= , MiniWW)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : Active Sync Mailbox continuously loading email when click on refresh on first auto retrieval.
2. Precondition : Email should be working 
3. Tester's Action:  Configure an Hotmail account -> On successful configure -> Open Mail box -> It show no messages in the folder ->while auto retrieval in the background -> Click on Refresh
4. Detailed Symptom (ENG.) : 
a.shows "No Messages in the Folder" while auto retrieval happening in the background
b.Emails never load in the mail box
5. Expected :
a. Loading message should display
b. Even on click of refresh button emails should load properly
6.Reproducibility: Y
           1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 393b3f57822ae0f34055c6a6060f1433136bafa0
9.Personal email id:  psingapati@gmail.com

Comment 1

5 years ago
Created attachment 750283 [details]
Logs for Refresh click while auto retrieval

Logs attached for refresh click, mail box continuously loading after configuring active sync account.

Comment 2

5 years ago
Hello Andrew,

The first issue "No Messages in this folder" is same as 868642

For the second issue , I have attached logs. Pleas check.
Thanks.
Flags: needinfo?(bugmail)

Updated

5 years ago
Target Milestone: --- → 1.1 QE2
(Assignee)

Comment 3

5 years ago
Taking this. Almost certainly a dupe of bug 868642.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Flags: needinfo?(bugmail)

Updated

5 years ago
blocking-b2g: --- → leo+
Whiteboard: [TD-28595] → [TD-28595], c=

Updated

5 years ago
Whiteboard: [TD-28595], c= → [TD-28595], c= , MiniWW
Jim, is this blocked on my feedback about your test_activesync_recreate problem requested on IRC?
(Assignee)

Comment 5

5 years ago
(In reply to Andrew Sutherland (:asuth) from comment #4)
> Jim, is this blocked on my feedback about your test_activesync_recreate
> problem requested on IRC?

Having that test pass would help some, but I think I'd need to write a new test as well. We could also check this in without tests for now, which I'd then follow up with a proper test (tests are hard!).

Comment 6

5 years ago
Whats the next step here?
(Assignee)

Comment 7

5 years ago
(In reply to Andreas Gal :gal from comment #6)
> Whats the next step here?

I talked to Andrew, and we're both ok with landing this without unit tests for now (they'd be fairly complex, and I've lost some time trying to unbrick my Leo device). I'll file a followup for the tests and land this in the morning.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 868642
(Assignee)

Comment 9

5 years ago
Created attachment 756109 [details] [review]
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/201

This fixes most of the existing tests (but not all). It doesn't add any new tests, but I'll try to get to that as soon as I can.
Attachment #756109 - Flags: review?(bugmail)
Attachment #756109 - Flags: review?(bugmail) → review+
(Assignee)

Comment 10

5 years ago
Landed: https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/201
        https://github.com/mozilla-b2g/gaia/pull/10115
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 126ca687b3d9494eb11c21437c474050452dc6bf to:
v1-train: 538e05f984f407fc003be8086e6b9ab76a1ff7e9
status-b2g18: --- → fixed
verified leo : 
Leo 7i build ; 
Gecko : 
Gaia   0154e3133ef811ca3e1fa192b4f1be653b8a40f1
BuildID 20130531114420
Version 18.0
status-b2g18: fixed → verified
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.