Remove cmd/macfe from the module

VERIFIED FIXED

Status

MozillaClassic
Macintosh FE
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: use leaf@mozilla.org)

Tracking

Details

(Reporter)

Description

19 years ago
The seamonkey module includes 4.7M of code in cmd/macfe, much of which is
clearly old codebase stuff which has no possible use in seamonkey, which the
entire world has to download every time they pull a tree.

Whatever part of this is needed for seamonkey should be moved to somewhere
appropriate, like widget/src/mac, and modified to use current headers and defs
rather than old ones like fe_proto.h and LINEBREAK, so that cmd/macfe and the
obsolete headers it depends on can be removed from the module.

Assigning to pinkerton because sdagley says pink knows which library it is
that's still needed.  If this is wrong, please reassign.

Updated

19 years ago
Summary: lots of old codebase stuff in cmd/macfe → [PP]lots of old codebase stuff in cmd/macfe
Status: NEW → ASSIGNED
the lib we need is interfacesStubs.mcp and can easily be moved.

accepting the bug.
Target Milestone: M10
setting for m10, just in case i run out of time.
Assignee: pinkerton → warren
Status: ASSIGNED → NEW
i moved the project that we still use into lib/mac. there is remaining stuff in
netlib, so i'm reassigning to warren for him to clean up. I'd rather not go
mucking with stuff during the Necko landing.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: warren → gordon
Status: ASSIGNED → NEW

Comment 4

19 years ago
I'll give this to Gordon for final verification, but I think we've got
everything we need out of cmd/macfe for necko.

Comment 5

19 years ago
*** Bug 12343 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
*** Bug 12343 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: gordon → sfraser

Comment 7

18 years ago
I've removed all dependencies on files in cmd/macfe. This directory can now be
removed from the module.

Updated

18 years ago
Assignee: sfraser → cyeh

Comment 8

18 years ago
Reassigning to cyeh to fix the modules file.

Updated

18 years ago
Summary: [PP]lots of old codebase stuff in cmd/macfe → Remove cmd/macfe from the module

Updated

18 years ago
Assignee: cyeh → leaf

Comment 9

18 years ago
cyeh tells me that leaf will deal with this.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 10

18 years ago
waiting on pinkerton's confirmation that it is no longer used.
ok, i built fine w/out it as well

LET'S REMOVE THIS SUCKER!!!!!!! ASAP!

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
done.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
Marking Verified per ok from leaf.

Updated

13 years ago
Component: XP Miscellany → Macintosh FE
Product: Core → MozillaClassic
Target Milestone: M10 → ---
Version: Trunk → other
You need to log in before you can comment on or make changes to this bug.