Payment screen never closes after switching to another app during purchase

RESOLVED WONTFIX

Status

P4
normal
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: rafael.medola, Unassigned)

Tracking

2014-10-14
Other
Gonk (Firefox OS)
Points:
---
Bug Flags:
affects-durango +
affects-moss +
affects-seahorse +
affects-seville +
affects-tricycle +

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 750403 [details]
screenshot

Steps to Reproduce:

1- Log in to MP;

2- Search for a paid App;

3- Click to the price button to star the purchase;

4- At the Bango screen press BUY;

5- Right after clicking BUY, skip the MP (home button) and Open the MP again;

Expected Behavior:

The purchase is completed without any problem.

Observed Behavior:

The purchase is completed but there is a screen about "payment completed" (with a loading gif) which never closed and the install screen is not available.
The App appears to the user list, but due to the bug871469 the user can't install.
(Reporter)

Comment 1

6 years ago
Created attachment 750404 [details]
log file
Krupa: is this a dupe of a platform bug?
(In reply to Wil Clouser [:clouserw] from comment #2)
> Krupa: is this a dupe of a platform bug?

After further discussion this may be on us.
Priority: -- → P4

Updated

5 years ago
Flags: affects-tricycle+
Flags: affects-seville+
Flags: affects-seahorse+
Flags: affects-moss+
Flags: affects-durango+
Version: 1.1 → 1.3

Updated

5 years ago
Duplicate of this bug: 909486

Comment 5

5 years ago
Created attachment 800466 [details]
payment_screen_stuck

I am adding a log with In-app stuck in payment screen, without the need to skip to home screen
Obs: slow data speed 2G network
Krupa, could you try reproducing the original STR to see if it's still valid? I think this is bug 843309 which is now fixed.

Updated

5 years ago
Assignee: nobody → krupa.mozbugs

Updated

5 years ago
Version: 1.3 → 1.4
(Reporter)

Comment 7

5 years ago
Same behavior in Hanger.

Comment 8

5 years ago
I am able to reproduce this behavior consistently on 1.1

Updated

5 years ago
Assignee: krupa.mozbugs → nobody

Updated

5 years ago
Version: 1.4 → 1.5

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Target Milestone: --- → 2014-10-14
You need to log in before you can comment on or make changes to this bug.