Intermittent crashtests/813372-1.html | load failed: timed out waiting for reftest-wait to be removed, 22 more, then a 7200 second timeout

RESOLVED FIXED in Firefox 24

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: philor, Assigned: mats)

Tracking

({intermittent-failure})

Trunk
mozilla26
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=23023764&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test crashtest on 2013-05-16 00:32:09 PDT for push 5a3f4463fcbb
slave: talos-r4-snow-044

00:38:29     INFO -  REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html | 1081 / 2415 (44%)
00:43:29     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html | load failed: timed out waiting for reftest-wait to be removed
00:43:29     INFO -  REFTEST INFO | Saved log: START file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
00:43:29     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/813372-1.html
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
00:43:29     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
00:43:29     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
00:43:29     INFO -  REFTEST INFO | Loading a blank page
...
00:48:29     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/base/crashtests/852293.html | load failed: timed out waiting for reftest-wait to be removed
00:53:30     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
00:58:30     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/forms/crashtests/367587-1.html | load failed: timed out waiting for reftest-wait to be removed
01:03:30     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/forms/crashtests/370703-1.html | load failed: timed out waiting for reftest-wait to be removed
01:08:30     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/forms/crashtests/370940-1.html | load failed: timed out waiting for reftest-wait to be removed
01:13:30     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/forms/crashtests/373586-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
01:18:32     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/225868-1.html | load failed: timed out waiting for reftest-wait to be removed
01:23:32     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/307979-1.html | load failed: timed out waiting for reftest-wait to be removed
01:28:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/324318-1.html | load failed: timed out waiting for reftest-wait to be removed
01:33:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/334105-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
01:38:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/337883-1.html | load failed: timed out waiting for reftest-wait to be removed
01:43:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/337883-2.html | load failed: timed out waiting for reftest-wait to be removed
01:48:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/339769-1.html | load failed: timed out waiting for reftest-wait to be removed
01:53:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/342322-1.html | load failed: timed out waiting for reftest-wait to be removed
01:58:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/343206-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
02:03:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/344557-1.html | load failed: timed out waiting for reftest-wait to be removed
02:08:34     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/345139-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
02:13:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/366021-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
02:18:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/369038-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
02:23:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/369150-1.html | load failed: timed out waiting for reftest-wait to be removed
02:28:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/layout/generic/crashtests/369150-2.html | load failed: timed out waiting for reftest-wait to be removed
command timed out: 7200 seconds elapsed, attempting to kill

https://tbpl.mozilla.org/php/getParsedLog.php?id=23015785&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23014523&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23013103&tree=Mozilla-Inbound
(all three on Win8 debug)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 4

6 years ago
Tweaked the test a bit:
https://hg.mozilla.org/integration/mozilla-inbound/rev/37b8fa6c1c92

Please reopen / file a new bug if it occurs again.  Thanks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → matspal
Target Milestone: --- → mozilla24
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 7

6 years ago
I can't reproduce the failure locally with Win7 / Linux64 debug builds and
I still don't see anything wrong with the test...

Last chance -- I disabled it on all platforms except Linux
(feel free to remove the test if it fails again):
https://hg.mozilla.org/integration/mozilla-inbound/rev/6caaf45d715c
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Assignee

Comment 8

6 years ago
We're in STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL ... and then the reftest
framework decides to load the next test anyway?  I don't understand this...
Assignee

Comment 9

6 years ago
OK, it did wait 5 minutes before moving on...
06:57:22     INFO -  REFTEST TEST-START | ... 813372-1.html | 1080 / 2414 (44%)
07:02:22     INFO -  REFTEST TEST-UNEXPECTED-FAIL | ... 813372-1.html

I'll push some debugging to Try and see if I can figure out what goes wrong...
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Disabled due to frequent failures.
https://hg.mozilla.org/integration/mozilla-inbound/rev/b8791c396e52
Whiteboard: [test disabled][leave open]
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 42

6 years ago
Looks OK to me. I think we can enable it again.
Assignee

Comment 43

6 years ago
Posted patch fixSplinter Review
Assignee

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [test disabled][leave open]
https://hg.mozilla.org/mozilla-central/rev/37747901aa72
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Target Milestone: mozilla24 → mozilla26
You need to log in before you can comment on or make changes to this bug.