If you place a call and then hang up just when it starts ringing, you can make the dialer app start up without causing the phone to ring

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: rexboy)

Tracking

unspecified
1.1 QE3 (26jun)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [mozilla-triage])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 750472 [details]
Screenshot

STR:

 * Place a call to a B2G phone
 * When the outgoing phone rings once or twice, hang up

Result:

 * The B2G phone shows the incoming call screen, but the phone doesn't ring, and screen doesn't show a phone number.  The incoming-call screen doesn't go away until you dismiss it.

This happens with both the Mozilla RIL and the commercial RIL.  It's a bit fiddly, but I can reproduce it more than half the time.

I tested on a Hamachi with
Gaia 9648799c2e45917ff150fa9eef8aeac79a9ac008
Gecko https://github.com/mozilla/mozilla-central/commit/175c59283b2055888a84965a27b79027eb784283
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
I saw this as well testing 1.0.1 build yesterday when I was working on the incoming call issue. I only saw it once during my testing session.
I saw it using the Commercial RIL:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/0b6bcb1f4175
Gaia   9648799c2e45917ff150fa9eef8aeac79a9ac008
BuildID 20130515070203
Version 18.0
oops.  dupping my bug to  this one.  didn't see it until now.

Updated

5 years ago
Whiteboard: [mozilla-triage]

Updated

5 years ago
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3
Assignee: nobody → rexboy
Created attachment 757243 [details]
Cleanup

This bug raises if calls end before callWindow.onload is called.
(Not so easy to reproduce because I need to hang the phone even before the ringback tone starts)
The patch should fix it.
Etienne, may you help review this patch?
Attachment #757243 - Flags: review?(etienne)
Comment on attachment 757243 [details]
Cleanup

Hello Rex,

Now that bug 823958 landed we shouldn't see these kind of issues anymore.
Can you try to see if the bug is reproducible on a gecko that has this patch?

It shouldn't :), the |onCallsChanged()| is now guaranteed to be called at least once [1] in |oncall.js| even if the call is not here anymore, so we will close the call screen automatically [2].

If all goes according the to the plan we should even be able to remove a bunch of the "exitCallScreen" workarounds.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/oncall.js#L294
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/oncall.js#L294
Attachment #757243 - Flags: review?(etienne)
Hi Etienne:
You're right, I can't reproduce this bug on the latest build of m-c anymore. Since But 823958 hasn't landed on b2g-18 yet, let's wait until it's landed and this bug should be automatically solved.

So the works we can do in this bug is, as you mentioned, cleaning the workarounds in dialer.js. I can try to do that and put up a patch if we agree to do it in this bug.
Thanks!
Depends on: 823958
Comment on attachment 757243 [details]
Cleanup

telephony.oncallschanged = function dialer_oncallschanged(evt) { ... } has already removed so I just remove the flag variable no longer used.
Attachment #757243 - Attachment description: patch → Cleanup
Attachment #757243 - Flags: review?(etienne)
Comment on attachment 757243 [details]
Cleanup

looking good :)
Attachment #757243 - Flags: review?(etienne) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 8b80bb4093a40c5e09541f2a56a3f85847907052 to:
v1-train: 60481ee9f9168bd39d43ff5de8e4d131ea926a39
status-b2g18: --- → fixed
1.1hd: 60481ee9f9168bd39d43ff5de8e4d131ea926a39
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.