Downloaded Messages with Attachements shouldn't have to be Re-Downloaded if Another Operation is used (e.g. save attachment, then copy message to local folder)

VERIFIED DUPLICATE of bug 46233

Status

MailNews Core
Backend
VERIFIED DUPLICATE of bug 46233
17 years ago
10 years ago

People

(Reporter: Peter Lairo, Assigned: Scott MacGregor)

Tracking

({perf})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010620, imap server

Downloaded Messages with Attachements shouldn't have to be Re-Downloaded if
Another Operation is used (e.g. save attachment, then copy message to local folder).

When i have a message with an attachment and save the attachment to disk, the
attachment is downloaded from the server. Why then does the message (including
attachment) have to be *re-downloaded* when i copy/move the message from my
online imap folder to a local folder. It seems silly to make the user wait for
the download twice.

There must be some way to make the cache smart enough to know that it already
downloaded that message 2 minutes ago.
(Reporter)

Updated

17 years ago
Keywords: mail1, mozilla0.9.2, nsCatFood, perf
Reporter: Is this still a problem with mozilla 0.9.4 ?
Keywords: mozilla0.9.2
(Reporter)

Comment 2

17 years ago
Yes, it is still a problem using build 2001-10-03, windoze.

I saved a large attachment (1.8 MB) to disk from my IMAP inbox and then dragged
the mail to my local folders, which downloaded the attachment a second time. ->
Very inefficient and time-consuming doing the same thing twice.
Keywords: mozilla0.9.6

Comment 3

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
reopening to dupe.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 46233 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.