When OS Windows 7 wakes up after sleep/hibernation Firefox doesn't respond to actions

VERIFIED FIXED in Firefox 23

Status

()

Firefox
Shell Integration
--
critical
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: Alexandr, Unassigned)

Tracking

({hang, regression})

22 Branch
Firefox 23
x86_64
Windows 7
hang, regression
Points:
---
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed in Firefox 23 by bug 836869])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

After waking up Firefox does not respond, but when i minimize the window and restore: browser has already reacted on my actions (mouse clicks), but is continuing not responding.
Only restart Firefox resolves the problem.

The problem appeared after updating to version 21.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 873109

Updated

5 years ago
Component: Untriaged → Shell Integration
Is your Issue reproducible when you disable the Hardware Acceleration under Options/Advanced/General and restart Firefox?
Flags: needinfo?(deflar)

Comment 3

4 years ago
XtC4UaLL: I can verify that disabling Hardware Acceleration resolved the issue on my machine.

OS: Windows 7 SP1
Browser: Firefox Version 21.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Flags: needinfo?(deflar)
(Reporter)

Comment 4

4 years ago
Disabling of hardware acceleration doesn't resolve issue. It is still reproducible.
But also, i noticed, it is reproducible when sleep mode lasts long. When sleep mode lasts short time it works fine!

Comment 5

4 years ago
I am having this exact same problem too.  OS is Windows 7 Home Premium 64-bit.  It happens upon recovery from sleep (not hibernation).  Processor is AMD E-450 APU.

As per the original reporter, the minimize and close buttons of the main window work fine, but opening up a new tab takes several minutes.  I have the menu bar enabled, and when I click on a menu item, the drop-down menu appears very fast, as normal.  However, when I move the mouse over various menu items, no menu item highlight appears on the item over which I am hovering.  I am using the "classic" theme of the shell.

I went to one of those "old apps" sites and downloaded and installed version 20.  This fixed the problem.  Disabling hardware acceleration does not fix the problem.  I normally disable hardware acceleration anyway to work around the "ugly fonts" problem.

Comment 6

4 years ago
Same problem. Firefox 21. Windows 7 64 bit. Toshiba Satellite L675D, 4Gb. Any action takes several minutes after wake up. Fortunately, closing by Alt-F4 works fine.

Comment 7

4 years ago
Same Problem, it's exactly described by those above.

Comment 8

4 years ago
I have the same problem since I have changed my CPU from a dual-core to quad-core (Windows 7, 64 bit, 4GB RAM). Both Firefox 21 and 22 do suffer from this problem, but Firefox 20 does not seem to be affected.

Comment 9

4 years ago
(In reply to Ronald from comment #8)
> I have the same problem since I have changed my CPU from a dual-core to
> quad-core (Windows 7, 64 bit, 4GB RAM). Both Firefox 21 and 22 do suffer
> from this problem, but Firefox 20 does not seem to be affected.

It does not help to run firefox in safe mode neither to switch of hardware acceleration.

Comment 10

4 years ago
I have exactly the same problem as well. Since the last Firefox Update, Firefox hangs up when the computer is woken from sleep. The only way to sort this is to restart Firefox. I am using Windows 7 Home Premium 64 bit.

Comment 11

4 years ago
Is there a way to modify this to include Firefox Version 22 or should a new bug be opened for that version as well for the same issue?

Comment 12

4 years ago
I also have this problem on my dosktop,I use Firefox 22 and Windows 7 x64 Ultimate.

Comment 13

4 years ago
Same problem here; Close/minimize work fine, but Firefox is largely unresponsive (some key presses are taken into account, but most aren't).

Any new Firefox windows opened while the first one is frozen are also frozen (they open fine, but typing into the address bar doesn't work).

Windows 7 x64, with AMD C-50 processor.

Comment 14

4 years ago
Many people say the issue have appeared since FF21 or FF22. So maybe there is a possible regression in one of these versions.

For users who are able to reproduce the issue every time, could you use the tool mozregression (see http://harthur.github.io/mozregression/ for details) to find a regression range (provide the changeset).

FF21 nightlies started in Jan 2013 (mozregression --good=2013-01-01).

You need to define a workcase: set a power on-off session easily usable so you'll be able to wake up your machine fastly after mozregression downloaded and launched the nightly build.
Keywords: regressionwindow-wanted

Comment 15

4 years ago
Same problem. Running Win7 Pro x64 SP1 on a Dell Optiplex 755. No problems with FF20.
Can you please test with the latest beta?

You can download it at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/Firefox%20Setup%2023.0b4.exe

Comment 17

4 years ago
I might be jumping the gun, but the problem seems to have disappeared in Firefox 23 Beta 5.

I'll report back in a few days after my laptop has suspended a few more times.  This might encourage others to try it though.

Comment 18

4 years ago
In my box the Beta 5 works fine too.

Comment 19

4 years ago
Firefox 23 Beta 4 from Honza's above link (comment 16) has fixed the problem here.

Comment 20

4 years ago
Reporter and B_Cisco, could you confirm it's fixed with the latest beta, please.
http://www.mozilla.org/en-US/firefox/all-beta.html
Flags: needinfo?(deflar)

Updated

4 years ago
Flags: needinfo?(trane63)

Comment 21

4 years ago
Sorry for the delay - very busy. Just installed the beta. Will let you know results ASAP.
Flags: needinfo?(trane63)

Comment 22

4 years ago
Installed FF23 beta. So far, this appears to have solved the problem (came out of sleep three times).

Many thanks.
Flags: needinfo?(deflar)

Comment 23

4 years ago
Installed Firefox 23 Beta 4 and the wakeup problem seems to be solved.

Comment 24

4 years ago
Many users reported the issue is fixed with Firefox 23 beta, so I close it. Feel free to file a new bug (or reopen this one) if the issue is back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → FIXED
Whiteboard: Fixed in Firefox 23
Thanks everybody for testing this!

Updated

4 years ago
Resolution: FIXED → WORKSFORME
Marking verified-fixed based on many comments.  This has probably been fixed by bug 836869.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
Whiteboard: Fixed in Firefox 23 → Fixed in Firefox 23 [bug 836869]

Comment 27

4 years ago
Question: I noticed that there is now a beta 6 version available. Can anyone confirm that this fix is in the new beta? Thanks.

Comment 28

4 years ago
(In reply to B_Cisco from comment #27)
> Question: I noticed that there is now a beta 6 version available. Can anyone
> confirm that this fix is in the new beta? Thanks.

The patch is in Firefox 23 since 2013-05-02 (when Firefox 23 was Nightly, now it's Beta).

Comment 29

4 years ago
Ok, after using the beta for a day or two, I can confirm that I no longer experience the issue.

THANKS!

Updated

4 years ago
Depends on: 836869

Updated

4 years ago
Duplicate of this bug: 859038

Comment 31

4 years ago
Hi, this bug seems to be the same like 890553

I can reproduced it on Win7 and FF22: 

-> Hibernate Windows 7 with FF22 still running
-> change date in BIOS to the next day 
-> resume Windows 7
Than its present!

FF23 works well...

Updated

4 years ago
Duplicate of this bug: 847266
My father encountered this problem and I got a remark from a friend of mind that had the same problem.
I couldn't find a moztrap BFT testcase for this (but that might be my lacking search skills). If there isn't, we should make sure we get one,
Flags: in-moztrap?(anthony.s.hughes)
What's the minimum amount of sleep time someone has to wait for this bug to occur? It seems, based on comment 4, simply switching in and out of sleep mode is not enough to trigger this.
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #33)
> My father encountered this problem and I got a remark from a friend of mind
> that had the same problem.
> I couldn't find a moztrap BFT testcase for this (but that might be my
> lacking search skills). If there isn't, we should make sure we get one,

What you testing with?  Which Firefox version?
Sorry, I can't tell, atm, I'm not at my parents place, currently. Iirc, it's on an amd64 bit machine, using Firefox 22.
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #36)
> Sorry, I can't tell, atm, I'm not at my parents place, currently. Iirc, it's
> on an amd64 bit machine, using Firefox 22.

This is confirmed fixed in Firefox 23.  Can you re-confirm with your parent's machine?  Thanks.
Target Milestone: --- → Firefox 23
Version: 21 Branch → 22 Branch

Updated

4 years ago
Duplicate of this bug: 903510

Updated

4 years ago
Duplicate of this bug: 890553

Comment 40

4 years ago
Hi all,

I commented on a duplicate bug https://bugzilla.mozilla.org/show_bug.cgi?id=859038, but figured I'd post here too.

I'm still experiencing this behavior in Firefox 24 Beta on OSX 10.8.4 ML.  Here's the graphics section from my about:support, let me know if you need anything else.

Device ID	0x1189
GPU Accelerated Windows	2/2 OpenGL
Vendor ID	0x10de
WebGL Renderer	NVIDIA Corporation -- NVIDIA GeForce GTX 670 OpenGL Engine
windowLayerManagerRemote	false
AzureCanvasBackend	quartz
AzureContentBackend	none
AzureFallbackCanvasBackend	none
Hi pmenon, could you please file a new bug for that and mention the bug number here?

Comment 42

4 years ago
Done: https://bugzilla.mozilla.org/show_bug.cgi?id=904958
Dropping the in-moztrap request since we lack the information to write a reliable, accurate testcase, and to ultimately decide if this is something which needs repeated testing in release. Please re-request if/when this information can be provided.
Flags: in-moztrap?(anthony.s.hughes) → in-moztrap-
(In reply to Honza Bambas (:mayhemer) from comment #37)
> This is confirmed fixed in Firefox 23.  Can you re-confirm with your
> parent's machine?  Thanks.

Yes, seems fixed, thanks. I haven't seen it back on my parent's machine on Firefox 23.0.1. They are using amd a6-3500 apu met with hd graphics 64-bit.

I still think a general moztrap testcase might be useful. Something like, have Firefox open, then set the computer in sleep mode for 10 minutes or so and then after wake up, everything should work fine.

Updated

4 years ago
Duplicate of this bug: 890553

Updated

3 years ago
Severity: normal → critical
Keywords: hang, regression
Summary: When OS Windows 7 wakes up after sleep Firefox doesn't respond to actions → When OS Windows 7 wakes up after sleep/hibernation Firefox doesn't respond to actions
Whiteboard: Fixed in Firefox 23 [bug 836869] → [Fixed in Firefox 23 by bug 836869]

Comment 46

3 years ago
I had similar symptoms and found out that it was an upgrade issue of LastPath addon. Not FF issue.
Versions:
	FF: 36.04
	PC: Windows 7
	LastPass: upgrade to 3.1.92
Symptoms:
-	Firefox can’t connect after PC sleep.
-	Trying to restart FF fails with a message indicating that a FF process is already running.
-	Attempt to kill FF process fails. Must restart PC.
Problem cause:
	Upgrade of Last extension left a file – ‘Install LastPass FF RunOnce.lnk			directing to ..\program files (x86)\common files\lpuninstall.exe
Apparently this file was meant to be deleted automatically after the upgrade but it wasn’t.
Solution:
	Delete (or disable) ‘Install LastPass FF RunOnce.lnk’ from startup directory. Restart PC.
You need to log in before you can comment on or make changes to this bug.