[B2G][Inari][Settings][USB] No access from PC to the internal memory

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: inarirun2)

(Reporter)

Description

5 years ago
Description:
A user is not able access the internal memory from PC, after USB cable is attached and "Enable USB storage" option is on

Repro Steps:
1) Updated to Inari Build ID: 20130515070208
2) Open "Settings" from the home menu
3) Connect the device to the PC via USB cable
4) Toggle "Enable USB storage" option in "ON" position

Actual:
No any information on PC that the device is connected and able to open the media data.

Expected:
Icon on the PC displays that the device is connected and the user is able to open the folder to view the media files

Environmental  Variables:
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

Notes:
Repro frequency: 100%
Q Analysts Test Team Priority: (Priority Levels: Pri 2
(Reporter)

Updated

5 years ago
Whiteboard: Inarirun2
this is working for me. 

Is the USB symbol appearing in the status bar? 
Have you check USB Internet Sharing is not activated?
Can you please re-test with a more recent build?

Updated

5 years ago
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 2

5 years ago
USB symbol appears only when you are tapping on "Media Storage" and then "Share using USB" enable, but expected result is when you are tapping on "Enable USB storage" under the "Storage" settings makes USB enable and connected with PC
Flags: needinfo?(sarsenyev)
(In reply to sarsenyev from comment #2)
> USB symbol appears only when you are tapping on "Media Storage" and then
> "Share using USB" enable, but expected result is when you are tapping on
> "Enable USB storage" under the "Storage" settings makes USB enable and
> connected with PC

Are you testing with 1.0.1? I think what are you describing are changes that were not applied to 1.0.1 so I marking this as tef-, please check which version are you testing and mark the corresponding flag.
blocking-b2g: tef? → -
(Reporter)

Comment 4

5 years ago
No, tested on Inari 1.1

Environmental  Variables:
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
(Reporter)

Updated

5 years ago
tracking-b2g18: --- → ?
(In reply to sarsenyev from comment #4)
> No, tested on Inari 1.1
> 
> Environmental  Variables:
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
> Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

If it was based on 1.1 you can request leo? for blocking for 1.1 release
(Reporter)

Updated

5 years ago
blocking-b2g: - → leo?
tracking-b2g18: ? → ---
(Reporter)

Updated

5 years ago
Whiteboard: Inarirun2

Comment 6

5 years ago
As long as the SD card can be accessed from PC on Inari, this won't be leo+.
Leo- this at this point, if there is any disagreement based on the information from comment#6, feel free to renom.
blocking-b2g: leo? → -

Updated

5 years ago
Whiteboard: Inarirun2 → inarirun2

Comment 8

5 years ago
we should recheck this on a more recent build, to see if this was a regression.  Also, what's the requirement for leo?
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 9

5 years ago
This bug came from a test case
https://moztrap.mozilla.org/manage/cases/?#bug-869381
The steps are:
"Attach the device via USB to computer with "USB Mass Storage" enabled.
There are now two additional volumes shown in the file explorer on the computer: 1.) corresponds to the device's SD card; 2.) corresponds to the /data volume on the device."
It also refers to the bug:869381
https://bugzilla.mozilla.org/show_bug.cgi?id=869381
Since this bug has "Resolved Fixed" status the new bug was created
Because as per TC, when you are connecting to USB the info pop-ups
Also see the bug 873247
https://bugzilla.mozilla.org/show_bug.cgi?id=873247
The default status is "Internal" which is not true
It's a Memory Flash memory, but not "Internal"
If remove a flash card, no any connection through USB is available
Seems like "Internal" memory is "data" memory
And SD card it's a flash card
So the test case clearly says about able to transfer files to phone memory not SD card
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 10

5 years ago
This bug came from a test case
https://moztrap.mozilla.org/manage/cases/?#bug-869381
The steps are:
"Attach the device via USB to computer with "USB Mass Storage" enabled.
There are now two additional volumes shown in the file explorer on the computer: 1.) corresponds to the device's SD card; 2.) corresponds to the /data volume on the device."
It also refers to the bug:869381
https://bugzilla.mozilla.org/show_bug.cgi?id=869381
Since this bug has "Resolved Fixed" status the new bug was created
Because as per TC, when you are connecting to USB the info pop-ups
Also see the bug 873247
https://bugzilla.mozilla.org/show_bug.cgi?id=873247
The default status is "Internal" which is not true
It's a Memory Flash memory, but not "Internal"
If remove a flash card, no any connection through USB is available
Seems like "Internal" memory is "data" memory
And SD card it's a flash card
So the test case clearly says about able to transfer files to phone memory not SD card
(Reporter)

Comment 11

5 years ago
This bug is not valid for Inari, Unagi, since those devices have only one storage option
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.