Firefox crash in mozilla::WebGLContext::GetActiveUniform @ fglrx_dri.so@0xdc0251 (reproducible on new Google Maps)

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Markus Popp, Unassigned)

Tracking

({crash, regression})

24 Branch
x86_64
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24 affected)

Details

(Whiteboard: webgl-driver, crash signature)

(Reporter)

Description

5 years ago
I just received my invite to the new Google Maps as announced in the Google I/O 2013 keynote. Went to test it in Firefox 24.0 on Linux (64bit), but only Lite Mode is available, also encountered some crashes.

As stated at http://support.google.com/maps/bin/answer.py?hl=en&answer=3031966&p=newmaps_no3d Firefox is currently only supported on Windows and OS X.
(Reporter)

Comment 1

5 years ago
Looking further it turned out, the problems seem to be new in Firefox 24.0, the new Google Maps works fine in versions up to Firefox 23.0.

Here is a report for the aforementioned crash:

https://crash-stats.mozilla.com/report/index/bp-b6ffb663-a704-4cfc-876a-d4ae32130517
Summary: Make new Google Maps available on Firefox for Linux → Firefox crash fglrx_dri.so@0xdc0251 (reproducible on new Google Maps)

Comment 2

5 years ago
Can you find the regression range using https://github.com/mozilla/mozregression?
Severity: normal → critical
Crash Signature: [@ fglrx_dri.so@0xdc0251 ]
status-firefox23: --- → unaffected
status-firefox24: --- → affected
Component: Graphics → Canvas: WebGL
Flags: needinfo?(markus.popp)
Keywords: crash, regression, regressionwindow-wanted
Summary: Firefox crash fglrx_dri.so@0xdc0251 (reproducible on new Google Maps) → Firefox crash in mozilla::WebGLContext::GetActiveUniform @ fglrx_dri.so@0xdc0251 (reproducible on new Google Maps)
(Reporter)

Comment 3

5 years ago
The Nightly of May 13 (the last being 23.0a1) is fine, the Nightly of May 14 (the first being 24.0a1) is the first one where the crash occurs.
Flags: needinfo?(markus.popp)

Comment 4

5 years ago
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d7ce90899997&tochange=81dd97739fa1
It might be a regression from bug 861039 or bug 738867.
Keywords: regressionwindow-wanted
If it's ANGLE version, we need to find out quickly.
It's interesting that this regressed on this setup, but the stack definitely looks like a bug in the FGLRX driver. Not something to be hugely worried about as long as it isn't known to affect other drivers (FGLRX is one of the two linux drivers that AMD is developing, and not the one that linux distros install by default).
(Reporter)

Comment 7

5 years ago
I just switched to using graphic drivers from here: https://launchpad.net/~xorg-edgers/+archive/ppa ... and now Firefox Nightly doesn't crash anymore. So it's very likely related to the driver that I used before, which was the proprietary driver from http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
Yup. This bug is legitimate, but it's still likely to end up as a WONTFIX as FGLRX users are only 2% of our Linux crash volume, and 0.02% of our total crash volume. I measured that on April 27 crash data though i.e. before the ANGLE update. I'm open to reconsidering the importance of this bug if this starts looking like this is getting a big deal --- I just don't expect so.
Correction: my data was skewed as there is a lot of crash for which we don't have any GPU information.

Among the Linux crashes for which we do have GPU information, based on April 27 crashes only, we have:

bjacob:~/crash-stats$ zcat 20130427-pub-crashdata.csv.gz | grep Linux | grep -v Android | grep OpenGL | wc -l
1537
bjacob:~/crash-stats$ zcat 20130427-pub-crashdata.csv.gz | grep Linux | grep -v Android | grep OpenGL | grep 'ATI Technologies' | wc -l
74
bjacob:~/crash-stats$ zcat 20130427-pub-crashdata.csv.gz | grep Linux | grep -v Android | grep OpenGL | grep 'NVIDIA' | wc -l
303
bjacob:~/crash-stats$ zcat 20130427-pub-crashdata.csv.gz | grep Linux | grep -v Android | grep OpenGL | grep 'Mesa' | wc -l
1159

So in summary,

  75% are Mesa (open source Linux drivers, what distros use by default)
  20% are NVIDIA's proprietary driver
   5% are FGLRX, the ATI proprietary driver

5% of Linux crashes is still just 0.05% of all crashes, still not a lot of people.
(Reporter)

Comment 10

5 years ago
(In reply to Benoit Jacob [:bjacob] from comment #8)
> Yup. This bug is legitimate, but it's still likely to end up as a WONTFIX as
> FGLRX users are only 2% of our Linux crash volume, and 0.02% of our total
> crash volume.

Do you have any channels to report this issue to the AMD folks so they fix the issue in their driver?

I don't know how these drivers are related, could that fact that the crash doesn't occur in the binaries from https://launchpad.net/~xorg-edgers/+archive/ppa mean that the problem is already fixed?

Always good to have a problem fixed where it originates from ... which probably is the proprietary AMD driver.
Whiteboard: webgl-driver
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.